Ikea tradfri outlet status not reported properly

have a few ikea tradfri outlets, all working fine when programming them (turning on and off) but if I add an tile on my dashboard to be able to manually turn them on and off, seems status is not reporting back properly. pressing the tile it turns either on or off, then a sand glass appears and seems the task is never completed. the device is way within the range of HE. any ideas?

In the IKEA Outlet's Device Details page on the Hubitat Hub, try clicking the CONFIGURE button to see if this helps to clear up the issue.

1 Like

grrrr I can't believe I ran into this again.... I recall I had this problem before and this was the solution! THANKS!


Yep - had the same thing happen to me yesterday (status not changing) and had the same reaction :rofl:

are these outlets not selecting the correct driver any longer?

Mike - it had selected the correct driver (at least in my case), but the on/off state was not correct until I hit "Configure". A refresh would correct the state - after "Configure" it has the correct state.

1 Like

FWIW, I've seen a few posts here lately where people say it paired with the correct driver (and they didn't change it), but it still needed a "Configure" to report properly--same problem as above.


These sometimes have a timing issue during pairing, I've made it a habit now to hit configure a few minutes after pairing them just to ensure they get configured.

Just saw this error in the log for the IKEA outlet. It's an old error from a couple of days ago when I switched drivers from the IKEA one to the generic zigbee and back again. Not sure which driver generated this error though.

dev:6812021-06-23 02:10:03.935 pm errororg.codehaus.groovy.runtime.metaclass.MissingMethodExceptionNoStack: No signature of method: ikeaControlOutlet.runOptionTest() is applicable for argument types: () values: [] (runOptionTest)

can this "configure" be automated somehow? as it happens quite often I thought that a "poll device" or "refresh device" I run every hour may solve the problem ? it often happens with tradfri outlets and quite annoying to always login to the ui and configure manually. even a "configure" button to a dashboard could help @rakeshg @martyn

This is something Hubitat should run automatically on pairing (in fact, at the platform level, device drivers with this capability do run this command on pairing, so unless they did something odd like declare it as a custom command, it should already be doing so). But, clearly, that is not working for a lot of users. Perhaps there is some device oddity (maybe it blanks out for a second or two after pairing instead of listening for commands?). Manually running the command sometime after should do it if you have this problem--and you should only need to do it once. The changes "stick." If you're doing it every time in an attempt to refresh the state, this shouldn't be necessary for that--and will also not fetch state on its own [EDIT: apparently, it also does a refresh in most drivers, so it might...but just a refresh should be enough in that case--and again, you shouldn't really need any of this in the first place]. (Definitely not something you should need on Dashboard, though there are ways to make that happen if you really need to for something.)

The Zigbee guru @mike.maxwell would be the one to ask about this specific device/behavior.

1 Like

Configure runs on device inclusion. It usually also calls refresh to get current device state.

If you need to call configure or refresh to get current device state on a regular basis then there's something wrong with the device the mesh or possibly the driver.

1 Like

the problem is that after let's say a week of usage it simply seems just lose contol , then I have to login to the admin ui and refresh the device. that puts stuff back to normal. annoying