I can’t ‘remove’ a z-wave device

The z-wave network was having trouble with some switch’s farther away from the hub, where they would work sometimes, and not others, and often had a 5 to 30 second delay when they decided to work.

I added 2 Aeotec Range extenders, and that that seems to have (mostly) resolved those problems. There is still an occasional long delay in some switches working, but at the moment it does not happen often.

So, since I cant remove the ghosts without having a PC, i supposed i am stuck with the ghosts.

It seems to me that this would be a problem that Hubitat could easily solve by building an app for this.

And, in case any Hubitat employees are reading this, I would gladly pay extra for a tool that would solve this problem.

1 Like

Yea, me too.
I have several ghosts from failed devices long removed and destroyed and no one seems willing or able to work w/Silicon Labs to resolve this. Not sure why. It's beyond frustrating that a vendor continues to allow ghost devices in a database without a "remove" option that works. This is the lingering reason when someone asks about Hubitat, I can't recommend it. Database basics gotta be managed first and foremost ... IMHO.

1 Like

Anyone who uses the Silabs SDK has this issue including Smartthings...

1 Like

I spent many years in a career in software. So, I know am over simplifying this issue, but I also agree with you. There has to be a simple solution to this rather straight forward problem.

As a way of an update:
I was able to get one of the ghosts resolved by re-installing the device that was a ghost (it was a light switch that was installed then uninstalled and it left a ghost even though it was removed in the recommended way originally). Reinstalling it, it found its way back on the network without my intervention. I did not need this switch, so I just left it in the attic, since I did not want to risk having another ghost from it again if I tried to remove it.

But, I still have a ghost. Nothing worked to remove one of them. I tried everything listed in this discussion chain. I currently have some strange behavior on my network occasionally, but no way to know if it is related to this ghost, or just random behavior from the Habitat hub. (EG: the switch shows "off" on Habitat, but the light is still "on" in real life.).

I am highly OCD, so the mere existence of a ghost is highly annoying. I would pay $$ to Hubitat if they would solve this problem for me.

It has been found that if the device lists any neighbors still ( >1 ) that the zwave chip immediately responds that the node is no longer in the failed list (even when it has just failed a refresh). Not sure if HE could brute force around this or not, but they seem unwilling to do so. Also doing that may void their Z-wave certification.

If you use the user created z-wave mesh tool you can see what the neighbor nodes are, and if you then exclude those neighbors, dropping the neighbor count down to 1, the ghost will be able to be removed.

Also, for your switch that you added back, if you properly exclude it, it will be removed. There is no way you did this before or the node would already be gone. Instead of clicking remove on the device page itself, I find it better to just run exclusion from the z-wave details and then put the device into exclusion mode. If it works the node will be removed, if it doesn't work then nothing will happen so no harm.


Thanks for the info.
Much of that went over my head. I'm not deeply versed in Habitat.
What is the "user created z-wave mesh tool"?
I have uploaded a screenshot of the "Z-wave details" screen from "Settings" showing the 'route' is empty. Choosing to "repair" from that screen eventually gives me a button to 'Remove', but it does not ever remove the ghost Node no matter how many times I press "Remove" or reboot the hub.

Its literally called Z-Wave Mesh Tool. [BETA] A Z-Wave Mesh Tool [C7 and 2.2.4+ Only]

You cannot remove the node because it still is showing neighbors.
You can see the exact nodes that are listed as neighbors using the mesh tool app I linked to.

Also, it is better to use Refresh to get the Remove button, it is much less intensive than repair.