I can’t ‘remove’ a z-wave device

You have to join the owners group to post photos (cuts down on spam bots): Hub owners - Hubitat

Also please watch the log when trying to do the remove and screen shot the error that gets logged. Might say something like Node is no longer in failed list.

If you just wait around 24-48 hours the mesh should mostly have figured out that node is dead and stop trying to route through it, and things will be back to normal. This is in my experience anyway. It still good to get rid of it but just saying if you are patient it will sort itself out.

1 Like

Thanks for the ‘owners’ tip. That worked !

I added a screenshot of my “Z-wave Details” list showing the item that will not “remove”.

The “Log” screen never shows anything. It stays blank. I will post a screenshot of that ‘blank’.

How about in the main hub Logs Tab, bottom left corner of the screen? The Z-wave logs rarely show much.

Aha. See attached. (New to this Hubitat thing. Thanks for the baby-step guidance.)

How confident are you at tinkering? You've got yourself a couple of ghost devices. I had a similar problem recently where the native remove option wouldn't remove a ghost. Luckily @danabw has written an excellent guide on how to use a UZB (or other Zwave stick) and SiLabs Zwave PC Controller to remove them. You can find it Here. In that post, he has a link to a PDF version of the process. i highly recommend downloading it and keeping it handy or even printing a hard copy for reference, I will add (and this won't make sense until you try it ) If you have a C8 hub, Smart Learn mode didn't work, I had to use Classic and remove it. But either way, it usually works really well.

You can pick up a UZB7 from Digikey for around $20. It's a handy tool to have around. I recently tried a Zooz 800 stick but did not have much luck with it.

Yeah that's the error I expected. There is still something wrong with the removal on occasion and everyone just points fingers at the other party and says it works fine here. Nodes that get stuck in "Pending" like that seem to be the worse. 95% of the time it seems to work fine these days.

If I had time to try and reproduce one like that I really want to get some zniffer traffic and see why TF the zwave chip thinks it is getting a response from a dead node. Supposedly the HE system just sends commands to the zwave processor and that is what is refusing to remove the device and kicking back the error message. The software on the zwave chip is provided by Silicon Labs. So it is a hard thing for the HE team to overcome.

Hmm... I have an idea. When you click refresh a couple of time do you eventually get a "Replace" option along with the remove? Do you have ANY other zwave devices you could pair there temporarily? If you could get a device paired into that node, you could then do a proper exclusion which will remove it!

Here are my instructions on doing a replace: [Guide] Updating Firmware and ZWave Replace

1 Like

@user4374 Do this, shut down the hub cleanly from the settings menu. Then unplug power for 5 mins. Power back up and then do a refresh/remove on that device again.

1 Like

Thanks for the idea. However, it did not work.
I tried this. Several times.
It does change the item to have a “Discovery” button. Which, does nothing when I press it.
Otherwise, the “refresh/remove” ends up in the same place, with the same message in the Log as in the prior screenshot.

If you know the device that created the ghost (usually the one right after it) disconnect power from it then reboot how I instructed above and try removing again. When something like this happens it's because the device is still pingable. That said if you still can't remove it you will need a z-wave stick paired to hubitat as a secondary controller to get rid of it.

rligthgow1: thanks for the idea. I shut down the hub, then shut power to my entire house (for 5+ min), then turned all back on. It did not have any effect on removing the ghost.

You have to shut down the device and try to remove it while no power is at the device that caused the ghost(s. If after that it won't remove you will need a z-wave stick


Aha. Well, I tried that. One of the ghosts, the device has been removed since it failed to pair. The other device, was successfully added the 2nd attempt. In both cases, I tried removing “while no power is at the device”, and both failed.

The software for z-wave stick uses PC. I only have Mac’s.

So, is my last remaining option (other fhan finding a friend with a PC), to “Reset Z-wave Radio”, and star all over building my network?

You can run parallels and a demo copy of windows. No need to nuke your z-wave radio. Even with the A1 chip

Is there an overview of how to do a “Reset Z-wave Radio”, that takes me through the process of rebuilding my z-wave network?

(Rebuilding Z-wave is less work than installing Parralels and WIndows on my Macintosh. And, even if not, my WIndows skills severely lacking.” )

OR, is there a support service that Hubitat offers to take care of this FOR ME? I will pay extra. Just want the bloody things to WORK properly.

First question to ask, is it actually causing any problems?
Once the other devices and hub realize that node is dead, in theory nothing should try to route through it, and it should not cause any issues besides just being annoying to look at.

1 Like

The z-wave network was having trouble with some switch’s farther away from the hub, where they would work sometimes, and not others, and often had a 5 to 30 second delay when they decided to work.

I added 2 Aeotec Range extenders, and that that seems to have (mostly) resolved those problems. There is still an occasional long delay in some switches working, but at the moment it does not happen often.

So, since I cant remove the ghosts without having a PC, i supposed i am stuck with the ghosts.

It seems to me that this would be a problem that Hubitat could easily solve by building an app for this.

And, in case any Hubitat employees are reading this, I would gladly pay extra for a tool that would solve this problem.

1 Like

Yea, me too.
I have several ghosts from failed devices long removed and destroyed and no one seems willing or able to work w/Silicon Labs to resolve this. Not sure why. It's beyond frustrating that a vendor continues to allow ghost devices in a database without a "remove" option that works. This is the lingering reason when someone asks about Hubitat, I can't recommend it. Database basics gotta be managed first and foremost ... IMHO.

1 Like

Anyone who uses the Silabs SDK has this issue including Smartthings...

1 Like