I can’t change time to 10PM

I am making a very easy automation in RM4. Turn on the lights at sunset and turn off at 10PM. Simple right? Take a look

Problem is that I can’t select 10PM. I have tried entering 10PM every way possible but RM sets it to 10AM every time. What gives? I don't know what to do. I have started over any number of times but it chooses 10AM.

I didn't have a issue?

What browser and device are your using when creating the rule?

Safari. I didn’t think of that. I will try it using Chrome. Let you know.

I just fixed it. I entered 22 in the hour box. I didn’t know I had to do that. Am I missing a setting? The display had the standard hour, minute and seconds boxes with AM/PM selector.

1 Like

Check you main settings, you can select regular or 24 hour time, the ui changes to match.

Just checked and it is set for 12 hour format.

That's a new one to me then, I would out of caution, go in and hit "save" and go back.

Just a note: I had this same issue with mode manager. I had it switching to Evening at 8:30PM but my dusk trigger offset from sunset was running into it, so I modified the evening trigger to 9:00PM.

Next day my mode switches to evening at 9am. I figured I screwed up. Edited again, and kept going to 9am. I deleted mode manager and redid it and it was fine.

Note 2: I am still on

Note 3: I was using chrome

Note 4: I never thought about trying 21:00. Now I feel like a dummy.