Hue Motion Sensor Red Light

I have a Hue Motion sensor connected with a Lutron Dimmer. Occasionally the motion sensor won't send a signal that motion is active. The log doesn't show it and a red light appears on the motion sensor when you first walk by it. After some time it will work and the light will come on. Any thoughts?

More likely that the sensor sent a signal, but your zigbee mesh is inadequate, so the hub never received the signal.

This is a symptom of needing more repeaters in your zigbee mesh. Hubitat documentation on zigbee meshes, linked below, explains the problem and the solution.

1 Like

@aaiyar is exactly right. It took me a while to figure out what the red blink means because I couldn't find it mentioned anywhere. The red blink means that it "sees" you but can't report it.

1 Like

With Hue Motion Sensors, a red light means motion is detected but the sensor is unable to communicate with the hub.

Perhaps the Zigbee mesh network needs another repeater between the motion sensor and the hub.

1 Like

Would a Hue Outlet work as a repeater. I assume you just have to check "Hub mesh enabled" to get it to work as a repeater? Or does anything Zigbee work as a repeater naturally?

Sorry missread that, yes with few exceptions line powered devices are repeaters.

1 Like

So you are saying the outlet plug would work as a repeater because it plugs into an outlet?

misread the post, yes.

"Hub mesh enabled" is for hub-to-hub sharing of devices has nothing to do with Zigbee repeatering. (Hub Mesh - Hubitat Documentation documentation)

Most (but not all) line-powered (plugged-in) Zigbee devices are repeaters.

I have a Hue motion sensor in my office behaving this way as well. Every few weeks it seems to lose connection with the hub giving me the red light on motion detection. The hub is also in my office, maybe 6' away. The battery, today for example, is 81%. I also tried rebooting the hub hoping this might reestablish the connection to no avail. The only solve seems to be to pull the battery to reboot it which is a pain since you have to unscrew the back. This worked today.

Curious if there are any other suggestions on what may be going on as this thing works really reliably for my use case other than these infrequent but frustrating disconnects.

Have you just tried "letting it ride" and see if it starts working?

edit: Plus, how about the paperclip in the hole in the back thing?

I solved my issues by adding Hue outlets as repeaters. I realize your hub is very close to the sensor. If possible, you might try changing the location of sensor slightly. Are you using a C-7 or C-8? The C-8 has external antennas.

I'm using a C7. I can't imagine it's a signal problem, none of my many zigbee devices have a problem and literally none are anywhere near as close as this sensor is.

Only in so much as I have left it for a day or two out of laziness to take the time to find a screwdriver to fix it. It hasn't come back on its own.

As for the setup button, I didn't try it this time but in the past i've tried it and I don't think it did anything other than put it in setup / pairing mode if you hold it long enough.

Also, I literally don't have an outlet closer to the hub than this sensor so any repeater I add will be even farther away :smiley:

Yeah, if you get into the add zigbee device page, it'll probably recognize it and re-pair.

I don’t know if a repeater in a different spot will definitely help in your case. But it’s worth keeping in mind that RF signal interference can cause seemingly inexplicable behavior like this for devices that “should be” close enough to the hub to connect without issues (to the human eye, that is).