Hublink stopped working after reboot

So I think this might be a bit of a bug, but after a reboot of my hubs, the hub link function I can't seem to restore. I have tried rebooting both hubs in different orders thinking it might need a certain startup order, but after several attempts, this did not seem to work.

I have enabled logging on the main hub, and then tried to go into the events for it, and I don't see anything, but maybe events do show up for these items.

If I go to the second hub and disable and enable hub link, I see this in the logs on the primary hub:
dev:2962021-05-01 03:01:21.006 pm debugparse locked
app:3292021-05-01 03:01:19.083 pm infoIP:, DNI: 86538b16-e661-412e-8465-53619e4e5c59_02, value: refresh
app:3292021-05-01 03:01:19.073 pm infoLinked Lock, Garage Door Lock, 86538b16-e661-412e-8465-53619e4e5c59_02,
app:3292021-05-01 03:01:19.069 pm infoVirtual Multi Sensor, Garage - Multi Sensor, 86538b16-e661-412e-8465-53619e4e5c59_AA7B, null
app:3292021-05-01 03:01:19.064 pm infoVirtual Multi Sensor, Barn - Multi Sensor, 86538b16-e661-412e-8465-53619e4e5c59_31E5, null
app:3292021-05-01 03:01:19.058 pm infoVirtual Multi Sensor, Gate - Multi Sensor, 86538b16-e661-412e-8465-53619e4e5c59_C298, null

So it looks like they are talking, but it is no longer passing updates.

Any ideas?


Don’t know what’s going on, but if I were you, I would replace Hub Link with HubMesh.

1 Like

Do you know what the differences are?

Is HubMesh replacing hublink?

Probably best answered by @bravenel or @gopher.ny

Hublink has been around for a few years and Hubmesh has been out for 6 months or so. I never used Hublink but read that it doesn’t integrate all attributes of a device. Hubmesh has been awesome because there are no drivers to install on the target hub and every attribute, commands, etc are available on the target.

1 Like

@ritchierich put it pretty well. Hub Link is an old relic from the very early days of Hubitat. It is basically obsolete at this point, as HubMesh is much better in every regard: performance, efficiency, ease of use.

Where do I find it? It is not under installable apps, it is also not in the documentation when I search for HubMesh.

It's a built-in feature, not an app (or driver):