Hublink IP out of synk?


My problem is that the IP address on my "linked hub" has changed but the IP address for the devices connected to the linked hub has not (attaching pictures where you can see that the linked hub has IP address ....206 but the device "garage lock" have IP-address ....205).
I can't find any instructions about how to resolve this...

As a complication I have a ISP provided router that does not have the possibility to assign/lock IP addresses to clients, so every once in a while the IP-addresses will change :frowning:

Change ISP, or see if another router, not provided by your ISP, will work.

Another approach is to double NAT by hanging a 2nd router off the back of your ISPs router. That way, if the IP supplied by your ISPs router to the front of your 2nd router changes, the addresses on your private LAN on the back of your 2nd router don’t change.

From your screenshot, it seems that your ISP assigns addresses in the 192.168.x.x range. Fine, choose as the LAN on the backside of your 2nd router the block 10.0.1.x so that there’s no possible conflict.

That’s how I am set up. We have dual internet service at our home (for redundancy). One has a static assigned WAN address (actually, 5 permanently-assigned public IPs), and the other is a gigabit Xfinity service that provides a 192.168.x.x address to us. I have a second router that we hang off the back of either WAN router, and it either is double-NAT to the Xfinity gigabit router, or single NAT on the static IP router. Our LAN off the back of the second router never knows the difference, never sees it when the path to the internet changes.

you can set a static IP on your hub

I respectfully believe that you are missing the problem faced by the OP.

1 Like

if the hubs are linked using IP address, and the router is not able to provide DHCP reservations, then you still need the hub to stay on the same IP address. wouldn't setting a static IP satisfy that need?

after setting the static IPs, then perform the hub mesh and they should be stable from there

Not if the hub is given a static IP that conflicts with an IP being handed out by the router’s DHCP server. From what was stated, there is no view into the router, no way to control its DHCP pool.

1 Like

What type of hub (c4, c5, c7)? I see that there is now a way to assign a static address in the hub itself. If you set the IP address there, put it outside the DHCP range that the router uses. For example, I have the router set to assign DHCP addresses in the range. I was reserving addresses in the and up range. My hubs are 130 and 125. I'm not sure with which update it came, but on the Settings page, there is now a Networking block. One of the options is to switch between a static IP address and a DHCP assigned address. I have noticed that once a static address is assigned, the next time I go to that option, the address does not appear there, but the hub continues to work with the assigned address.

I hope this will be helpful.

Sometimes you can set an address above the DHCP pool and still get an internet connection, sometimes you cannot. Depends on the router. Give it a try. If that works, then setting the hubs to static IP ranges above what the ISP router is handing out will work.

1 Like

Great! This is working so far! I set the IP addresses on my two C-7 hubs in "Networking" above the range specified in my IPS-router and they still get those IPs.

Thank you!

1 Like

Thank you! This is working so far :slight_smile:


Good! I'm glad it is working for you.

1 Like