Hubitat with Sengled Bulb - Incorrect State Captured

Current infrastructure notes at bottom of thread.

I'm running a Hubitat C8 system using Sengled Colour bulbs and Innovelli Blue light switches. My problem is the Hubitat system is not reporting the bulb state properly. I have used the button controller app to program the light switches witha few basic commands to turn bulbs on to soft white in the bedroom. The lights turn on ok, but when I turn them off, some may turn off while others stay on. If I hit off on the switch again, sometimes they turn off, sometimes they continue to stay on. This does happen all throughout the apartment, but we'll focus on one room for now. It is seemingly random as to when it will happen.

On the device page for the bulbs that are stubborn, they show a state of off although are physically on. If I issue other static commands that change the colours of the bulbs, the bulbs respond to those commands, but do not respond to off commands. I can refresh the status of the bulb in the Hub device page and the state then changes to on, or I can physically unscrew the bulbs for a few seconds and the back in to do the same. This allows the bulbs to respond to the off commands again until it breaks again.

I intend to move my Hub as it is directly beside my router and I'm concerned the 2.4GHz band is interferring with Hub functionality, so I have the option to move it from mere inches away from the router to 15ft away on another LAN switch.

I have considered switching the bulb driver from Sengled Element Color Plus to the Advanced Zigbee bulb as a test, but thought I'd ask the forums for guidance as well as I continue to troubleshoot.

Hubitat C8 - 2.3.9.143
Sengled Colour Bulbs - 26 in home (no radio)
Innovelli Blue Light Switch - 9 in home plus aux for 3 way switch (radio)
GE zigbee fan switch - 2 in home
Third Reality zigbee plug - 4 in home (radio)
Home - 1200 sqft - 2 bedroom apartment

Have you properly separated your 2.4GHz WiFi channel from your Hub's 2.4GHz Zigbee channel? Make sure to only use 2.4GHz WiFi channel 1, 6, or 11 - with a 20MHz channel width. With that sorted, be sure to use Zigbee channel 15, 20, or 25. This will prevent WiFi and Zigbee inteference.

Have you tried using Zigbee Group messaging, which allows multiple bulbs to be treated as a single device. This is very useful when you have multiple bulbs in a single light fixture, for example. It also drastically reduces the amount of Zigbee traffic, thereby improving overall Zigbee mesh network health.

The simplest way to do this is to use the Hubitat "Groups and Scenes" app, to create a "Group Device" for a collection of Zigbee bulbs. Then simply use this single "Group Device" in your automations instead of a bunch of individual Zigbee bulbs.

It would also help if you could please publish some screenshots of your automations that are not performing properly. This will allow the community to help troubleshoot.

1 Like

PS - 26 bulbs in a 2 BR apartment? That's a whole lotta bulbs! :wink:

I hate to think what you would say about the 30 RGBW bulbs in my living room. :sweat_smile:

1 Like

Ok, so for now I'm going to start with the channels and let it settle. You're right the bands were too close together so there was overlap.

Keeping focus on one room, the bedroom. I've pasted a screenshot of the button controller entry. So when I hit up once on the bedroom switch, I get the three bulbs to set to a soft white colour and turn on. I have the every bulb set to allow for colour and level setting changes without the bulbs turning on unless you also specify they turn on. When I hit down once, a simple off command.

I will take your suggestion and create a grouping for the three bulbs so that they act as one virtual device since they are getting the same commands. In this case, when I turn the bulbs off, one or more for this room will stay on. If I hit the switch down again, sometimes they'll go off, sometimes they'll stay on with a device status of off.


Below i have additional complication because I like to have coloured lights. When I hit the scene button on the side of the switch, I set the 3 bulbs in the room to different colours, but I still use the same off command when hitting down once. Sometimes the colour doesn't get set right and if I hit the scene button again, it sometimes corrects, sometimes no change at all. When that happens, i hit up once to set them to soft white, and then the scene button on the side again and it corrects. It's entirely possible I'm using the wrong commands to set the level of the bulbs for this room, but I haven't foujnd the correct command for it if this is not right. Can I still use the grouping if the 3 bulbs have different colours? Or is that only useful if the bulbs need the same command?

As far as automation goes based on day, below I have my various lights turn on via Rule Machine an hour before sunset. Eventually, i'd like to get this working with a sensor that is triggered by a light lumen threshold I set as sometimes the overcast days make my apartment dark. I'd like the living room lights to turn on when it gets too dark in the place.

5 living room lights turn on with their various colours, wait half an hour, turn on two hallway smart plugs that have lights attached, the office rope lighting that is controlled via smart plug, and the 3 bedroom light bulbs. I notice the bedroom doesn't always set the correct colour. Just tonight bedside left was set to yellow instead of Cyan, see the logs below the evening lights rule.


image

Side note, I noticed that actions were happening while I was sleeping and I definitely don't have automations running during that time, nor do I think I was sleep walking :wink: I don't understand why it kept flipping between orange and cyan during that time.

For what it's worth, I have a lot of Sengled bulbs that are a bit slow to get the message. I wound up writing an app called Groupthink that repeats commands to group activators until all the bulbs are at least on or off properly.