Hubitat with Homemade Temperature, Humidity, Pressure and Light sensor


#442

Thanks. let me know what you find.


#443

I have had a Lowe’s Iris Zigbee Outlet and Motion Sensor paired to the C-5 with no problems. This is the first device that I have had a problem with. I may try unpairing my other Environment Sensor from my C-4 hub to see if it has the same issue on the C-5.

UPDATE: I tried moving my second Environment Sensor to the C-5 hub and it behaves exactly the same as the first one. I re-paired it with my older HE hub and it works perfectly once again.


#444

Sounds very similar to the issues that I have with my three sensors (you can see all the details earlier in the thread), albeit they are on an original C4 hub. The sensors work fine on my old SmartThings hub, I just could never get them to stay paired on Hubitat with the same cycling that you are seeing @ogiewon

Unfortunately I've not had time to do any further troubleshooting with a ZigBee sniffer, but in the meantime I've added many more router and end devices to Hubitat all without issue.

Definitely interested to hear what you may find out @ogiewon and @mike.maxwell as hopefully it will mean I can finally use these sensors!


#445

Which 3 sensors specifically?


#446

My two sensors are slightly different from each other. Neither of them are the ones with user definable I/O pins.

Here is the original one (which now has the capacitor reattached)

https://community.hubitat.com/uploads/default/original/2X/7/74e31831b54766340db5c6249c3155bddb05bd87.JPG

And the second, slightly newer one (the one on the right in the picture below)

image https://community.hubitat.com/uploads/default/original/2X/a/a3cd9c6cc637cf9da826c76490571c9fe7f0ca48.jpg


#447

I have an original, and a newer one with io setup.

I wasn't able to figure out if the three sensors that @martyn was talking about were environmental sensors of some other device.


#448

I believe he is having issues with the same custom Environment Sensor made by @iharyadi. Here is his first post, earlier in this thread, where he mentions the issues he's seeing.


#449

Hi Mike, Martyn has the latest variance of my sensors. It is exactly the same as the one you have have with IO setup.

Dan has much older versions.

In any case, all those sensors has the same Zigbee stacks. As the time goes, I only add application level support (Cluster, ZCL).

Thanks for the help. let me know if you can reproduce the issue with one of your hub.

Iman


#450

How long did it take to drop?


#451

It dropped within ~30 seconds of being connected. Using the "Add Z-Wave or Zigbee" device discovery tool resulted in the message about a device has been re-added and initialized. It could never finish populating all of the attributes before dropping again. I tried using Iman's driver as well as yours. Same result.

Both sensors work on my two other HE hubs (C-3 and C-4.) I performed a full factory reset on the C-5 yesterday to make sure I was starting from as clean a slate as possible. I like the new reset process. Very easy and user friendly.


#452

Interesting, I joined the one with io two hours ago, it's been pumping data every minute since the initial setup. I'll add the older model in the morning and see if it's any different.


#453

Hi Dan,

What is the frequency/channel that you use on the C-5?

Thanks
Iman


#454

I believe tried it on 15, 18, and 25. It always behaved the same way.


#455

Thanks, I was going to try the frequency that you are using. Since, you have tried multiple frequency, I do not think it is an issue. Those are frequency that I have used in the past as well.

I do not have a hub that I can reproduce the issue. The only thing that I can think about is to see what is being pass back and forth between the hub and my sensor. Then, do comparison between the hub that work and that does not work.

I have a sniffer. I just do not have a hub that seeing this issue for this step.

Thanks
Iman


#456

well this is interesting, removed my v1 sensor from one of my hubs, now it won't join anything, not the hub it was removed from, nor any other hub.
The LED isn't illuminated, but honestly I can't remember if it was illuminated before or not.


#457

Hi Mike,

You may want to factory reset it.

  1. Unplug the sensor.
  2. press the button on the back
  3. Plug back to the power and count for 4 to 5 seconds.
  4. Release the button.

It should try to pair again.

You has a couple sensors from me. The old one does not have any LED.

On the new one, the LED is tide to charging circuit only. They are not related to Zigbee at all. If you see couple LED on the back and they are not power on. It meant the power circuit is toast. I can try to fix it for you.

Thanks
Iman


#458

reset did it, my V1 was able to pair on a C5 hub and report all attributes without issue, hasn't left in the first 5 minutes, will keep an eye on it.
It's running on channel 15 currently.


#459

Thanks for giving it a try.

@mike.maxwell - when you tested, was your C-5 running v2.0.5 or v2.0.6 firmware? Lots of zigbee changes in 2.0.6... :thinking:


#460

2.0.6, however those zigbee changes shouldn't have had an effect such as this.


#461

I am running some custom code tests on that C-5 currently (unrelated to Zigbee.) I'll try pairing these sensors again once I get some idle time on that hub so I can upgrade it, just to satisfy my curiosity.