Hubitat update (2.3.8.138) wiped my static IP addresses

I don't see any posts about it in the beta section, unless someone mentioned it in the giant thread regarding the database engine update. Which would not have been the proper place to report it and would be easy to miss. There is only one other post from the recent beta round, and its not about a static IP.

1 Like

Odd, I don't remember seeing that. Can you send me a PM w/a link to the post?

1 Like

Just updated mine from - .133 to .138
Hub is set to fixed 100 and dhcp router set to static IP for HUB using mac.
everything was fine with network after update, ¯\(ツ)

2 Likes

Believe @Vettester mentioned that he'd lost his settings, but that was the only one that I recall seeing and would have been real easy to miss (I had completely forgotten about it until I saw this) as we were concerned about CPU, memory and a little about DB size.

2 Likes

Found it - it was as you suggested, it got lost in the giant thread on the database engine. Both C5 hubs, interestingly. It was @Vettester who posted below:

https://community.hubitat.com/t/2-3-8-135-updated-database-engine-just-a-little-bit-more-on-this-please/136078/14?u=danabw

@gopher.ny @bobbyD : Another data point on losing fixed IP set on the hub after the .138 update. Good memory, @kevin.

1 Like

This issue was actually reported 3 times within that thread.

Screen Shot 2024-04-09 at 4.03.52 PM

4 Likes

Excellent, thanks for the additional details. Should help getting this tracked down. We should have separated the networking issues from the known database/cpu/memory issues that the giant topic was focused on. :slight_smile:

And... this is why I always make all separate issues in a new thread. I hate the giant beta megathreads of various issues reported in various replies, and I have no idea how the devs keep it all straight.

6 Likes

I think I get why it happens now... fix is coming.
A hub reboot should bring static IP back, too, on its own.

8 Likes

New build has dropped with the fix. Thanks @gopher.ny!

9 Likes

There may be a more responsive dev team somewhere in the universe, but I kinda doubt it. :wink:

15 Likes

Did all your hubs come back? I updated my static IP hubs to the dreaded .138, and while I was able to get my C-7 back, my C-5 showed up for a little while, but then went "network silent" ever since. It is still running, as my Zigbee and Z-Wave devices are still doing what they're supposed to be doing, but on the network side, totally unresponsive. Tried different subnets, power cycling, all the "finding hubs" procedures including MAC address searches, but no joy. I'd hate to start from scratch, but not sure what to do next.

If you are using hub mesh then settings -> hub mesh will show you the current ip addresses

An excellent idea, and I did try that, but the entry field is blank (where once it was populated).

Do a network reset. Hold the hidden button on the bottom for 7 seconds. That will set it back to dhcp.

2 Likes

Provided there isn't something wrong with the router itself, I would double check your mac address in the table and make sure there are no weird things like spaces. (while spaces should be rejected, I've seen some weird stuff with consumer grade products)

1 Like

I'm having a slightly different issue. My C7 was using DHCP with a static IP reserved on the DHCP controller. This has been a working configuration for years.

After updating from 134 to 139 (didn't touch 138 at all), my C7 doesn't respond on the ethernet connection. I've tried the 7-second hidden button reset, but it hasn't resolved the issue. I removed the IP reservation in hopes it would pull a new/different IP, no such luck.

findmyhub.hubitat.com "Connect to Hub" doesn't work and still points to the original IP, leading me to believe my C7 isn't connecting over Ethernet at all.

I setup an old router and connected my C7 to that and it still doesn't pull a DHCP address. Tried the 7-sec hidden button again as well and still nothing.

Note: Initially my C7's Z-Wave and Zigbee were semi-functional, i.e. Zigbee motion sensor triggering rule to turn on Z-Wave light switch, after the update's reboot. However, since the initial 7-sec hidden button usage Z-Wave and Zigbee devices in my home are non-responsive leading me to believe my C7's Zig & Z radios are offline now.

A BIG thank you to @jtp10181 as your suggestion was spot on. Pressed the button for 10 seconds while hub was on, then the hub turned blue briefly, then green briefly, then blue again for an extended period, and finally green again, at which point the C-5 hub became discoverable. First action - make a backup. Second action, update to .139. That's probably the closest I've been to bricking a device from a manufacturer firmware update. Again, big thanks to the Community and Jeff Page.

1 Like

I'm just going to add this note to my experience, in case it helps someone else searching this thread. Regarding the updates, I have 3 C-8 hubs on a different install on a different network. All three were running firmware 2.3.6.146. Two updated without issue. When trying to update the third one, it became unresponsive for long periods of time when clicking the notification in the upper right, and attempting to download a backup. Long periods of time means a half-hour to an hour or more. Here's the weird part. During one of these long periods of unresponsiveness, I ran an instance of AngryIP (v2.21), an IP and Port scanner. The moment AngryIP touched the hub (at xxx.111), the hub became responsive, even before AngryIP had finished outputting the scan results (hub webpage was open in a concurrent browser window). From that point on, not only was the hub responsive, but perhaps even "spritely." Maybe it's because, in contrast, anything would have been "spritely." Anyhow, not sure why, but wanted to put that out there in case it helps anyone else. FWIW.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.