Hubitat Safety Monitor contact sensor not working?


I think I have Hubitat Safety Monitor configured and armed correctly, but something seems to not be working. I have a contact sensor ("Front Door Contact") included in both my Armed-Away and Armed-Home HSM triggers, but I first noticed something was off when the motion sensors I also have included for Armed-Away triggered my alert instead of the contact sensor that should have been the first thing. I then tried testing it myself and intentionally trying to trigger an HSM intrusion when in Armed-Home mode, where I only have this contact sensor selected, but nothing happened.

At first I thought it might be because I have a 5-second delay configured (what happens if a contact sensor is opened then closed before the delay is over? I want the intrusion alert to still happen, but I don't think that's a problem here because I tried both opening and closing it and leaving it open, and neither worked). I also don't think there's a problem with my contact sensor because it's logging open/close events like I expect on both the device page and hub logs.

I have screenshots of my configuration and the hub log below. Can anyone think of anything I'm doing wrong?

The alert is staged to run in the number of seconds of the delay. It doesn't matter if the door closes again, the alert should still go off.

I will set up a similar HSM situation and see if I can reproduce your situation.

I found a bug in HSM, but not one that explains your situation. The bug was such that the delay was not being honored, and the alert would fire immediately.

That leaves your problem somewhat of a mystery. My setup was a door with a contact sensor, and armed home intrusion alert. Could you try a different alert? Perhaps there is an issue with the sirens. I uses a Pushover notification for my alert that worked. You could try turning a light on, or Pushover if you have it.

I should have clarified that my alert mechanism, the siren devices (and SMS I have set up for Armed-Away), do seem to work since everything fires successfully from Armed-Away when I have both the contact and motion sensors as triggers. I have the option to place the name of the device that detects the intrusion into the text message as well, and it always says the motion sensors even when the contact sensor on the door should have been the first device to detect it. In Armed-Home, I only have the contact sensor specified and can't get that device to trigger an intrusion no matter what I try. I'll keep playing around with different types of alert and other "trigger" devices (this is an Iris contact sensor on the generic driver, if that matters) and see if I can get anything to work--thanks for trying to replicate my problem.

EDIT: I removed the sirens, used a push notification (not Pushover but a community ST Notification pusher app) instead, and also switched the contact sensor for a motion sensor to see if it worked. It did. Then I put everything back the way I had it before: contact sensor and sirens. Somehow, it works as I expect now--not sure what was going on before!

I will consider this problem solved, but I'm not sure how since I'm pretty sure I just tried something else and then re-configured it the way I had intended. :slight_smile:

PS - Funny you should mention the delay. Glad to know it still works like I'd expect (I figured, but initially wasn't sure if my problem was caused by a misinterpretation). Also funny that you found a bug, as at least the intrustion-alert delays seem to working for me, but with only a few seconds of delay it's hard for me to really tell (not sure about the arming one but I haven't noticed any problems there either).

Further to my last post: The delay being ignored wasn't a bug at all. Intrusion delays are there only for Armed-Away intrusions, to allow time to disarm the system before the alarm goes off. If you have it Armed-Home, the alert should be instantaneous because you are not expecting those doors to open (otherwise, why put them in HSM). That explains why my door instantly alerted me -- it was in Armed-Home.

It could be that by hitting Done in the app -- that refreshes subscriptions -- it was cleared from some messed up state.

1 Like

Hi. Im having the same problem (not the delay) my door sensors wont trigger the alarm but the motion sensor does.
I can see in devices that the door sensors open.