Hubitat refusing connection from a browser and the ios app

I am having an ongoing issue and was wondering if anyone has had the same issue. After running without issues, my H/E stops connecting to web when I connect via the IP address and the app doesn't connect either. I pull the power cord and restart the hub successfully but in a few days or weeks it happens again.

To try to answer some of the questions you may have:

  • I am running a standard set of drivers, no third-party drivers.
  • I am not running any custom code.
  • I have mapped the MAC address to a static IP in my router.
  • I am trying to connect to H/E via a straight IP address
  • H/E continues to run normally, controlling my devices when I can't connect to it.

Do y'all regularly reboot your H/E?


Three things to try:

There is the possibility that the hub’s database has become damaged by this. When the non-responsiveness happens, have you tried accessing the diagnostic tools menu at YourHubIP:8081 ? If so, see if you can back up and do a soft reset, then restore an older DB backup or the one you saved.

When this happens, are you able to see your hub on your network using a network scanner such as Fing, etc? There’s a remote possibility that it has given up its DHCP lease and gotten another.

When this happens, are you able to access your hub through

The only time I have rebooted my hub is after firmware updates or during the dance to remove ghost nodes, which hasn’t happened since the recent flurry of firmware updates.

1 Like

I can see the H/E when I look at my router and its at the correct IP. I've used my router functionality and assigned the W/E mac address to a fixed IP so it will never have a different IP.

I never knew about the diagnostics on port 8081. I see Restore, Set Date/Time, Reboot, Shutdown, Safe Mode, Soft Reset, Full Reset, Login. I don't see a backup option. Should I do that from the normal menu? Won't the backups also have the damage?

Should I see some sort of option to scan my database?


It’s my understanding that damaged parts of the database aren’t backed up, perhaps because some sort of a sanity check is done during backup to prune the bad parts out.

So, if by some means you are able to get (or have) a good backup, then the soft reset clears out the existing database so that a good one can be installed.

It’s my personal opinion that the database is somewhat fragile, but that’s a result of the database software that was chosen.

Because you say you are able to see the hub at its correct IP, then it’s not crashed, and using the diagnostics tools to do a clean shutdown and/or reboot should be possible, making the plug pull unnecessary.

Documentation on the diagnostic tools is here:

1 Like

Most types of corruption is excluded since the backup is actually "just" a DB dump.

The above advice is good regarding backups (download them locally to your computer) and SOFT reset. Just want to point out that a FULL reset should NOT be done without being instructed to do so by support or, possibly maybe, by a community member known to understand when and why to use it (which is basically never) :wink:


As of today, I am unable to connect to my HE hub with any browser. The hub stopped responding sometime in the last 20-hours. I unplugged/replugged it. Sensors, lights, IoS Dashboard, etc. all work.

However, I cannot connect to it via any browser. Connection timeout. Help?

Sounds like there is a good chance it changed its IP. Do you have a DHCP lease reservation for your hub in your router? Can you locate your hub at ?

Not a good idea to unplug/replug. See posts earlier in this thread.


I have this same problem. I have found that disconnecting my wifi and reconnecting it resolves the issue. You may have to do it a couple of times.

672southmain I'd reset the wifi, but tried again. My HE hub finally appeared via and, as you correctly said, it changed its IP. Thank-you!