Hubitat no coming up

I tried to update my Hubitat, but it never came up after the firmware update. I went to the diagnostic tool and tried a reboot and that failed. I went back into the diagnostic and shut it down the unplugged it and and plugged it back in still not able to get it to come up. I then tried a soft reset, didn't work. Then I did a full reset, still not coming up. Nothing seems to work. I'm extremely disappointed that firmware update can break my Hubitat.

Welcome to the community, sorry you are having these troubles. I have alerted support.
Tagging @bobbyD

1 Like

Which version of diagnostics tool is it running? It will be in the Hub Information section:



IP address

Ok, that's an older version of diagnostics tool. We hid the full reset options by default in more recent ones.

Does the older version show in Restore previous version selection similar to the screenshot? If yes, please try rolling back to it.


If not, please run this command from command prompt/terminal. The command will return quickly, but download itself will take a few minutes.

curl -s -X POST



Current running 2.25.122

Actually it's running Sorry!

Hmmm, if you full reset the hub, a version shouldn't matter much... it will show the welcome green screen. Please try switching to first, and to if that doesn't come up. It seems that your hub has the latest version, there's no need to try and download it again with curl.

Okay I did a roll back to It came back vary quick saying that it was successful and redirecting to web interface. Then I get a page that says This site can't be reached. refused to connect.

Now it shows the version is in the diagnostic screen. Still can't get to the hubitat screen.

Rebooting now.

Waiting for hub to reboot.

Hub is responding to a ping.