Hubitat.local Issues - Once Again

I've posted about this before and after trying several suggestions and troubleshooting on my own, I still have this problem where "hubitat.local" fails. It reports DNS_PROBE_FINISHED_NXDOMAIN, which means domain not found.

I have lots of devices on my LAN (Synology NAS, 3 ESP32-based devices, rpi, Linux and Windows boxes, wireless router, LAN printers, etc.). Under Windows, every single device can be accessed by its "(hostname).local" EXCEPT for the Hubitat (C7, version 2.38.125).

I have tried many things to get "hubitat.local" to work. Installed/removed Bonjour which makes no difference. Tried it on 4 different browsers- no difference. Disabled firewall + Windows security, no difference. Tweaked multicast and DNS registry entries. Nothing fixes Hubitat.

Note that this works 100% under Linux but fails only on Windows. I just can't believe this is a Windows mDNS issue because every "(hostname).local" device on the LAN works perfectly. I can force it to work by adding a line into the Window hosts file, but that is checked after mDNS fails so I would expect that to work. This happens on all 3 or my Windows boxes.

This may not be a big deal to some, and yes, I can access the hub using its IP address. But perhaps something is not right with Hubitat in the way it responds to mDNS queries. This used to work in the past and I don't remember which versions, but now it appears to be broken.

I was just talking about this yesterday !

Mine is the same way .. I am not sure what it is and I use windows also ..
I have tried turning on muti-cast on the router and other stuff.
seems like it only wants to work for apple users :confused:

Make sure you are using the name defined in Settings: Hub Details:
Screenshot 2024-04-01 at 3.56.47 PM
lower right.

Mine won't answer to hubitat.local either, but ninthhubitat.local works fine :smiley: Of course, I'm all Apple here.

1 Like

http://hubitat.local/ works for me on my C8.

Mine works as well. Mine isn't Hubitat dot local, I gave it a unique name, so Hubitat dot local bombs out, but works fine once you use the correct name.

Did you try clicking the link on the Settings > Hub Details page?

Any pihole or other blocking hardware/software on your network? What network equipment are you using? My network is a very simple consumer grade TP link router.

1 Like

You using windows ? What ver ?

Windows ?

Win 10. Wired ethernet on both the hub, and my desktop.

Now what didn't work is using my Android phone browser, connected to my local network only (cell data off). I guess I didn't necessarily expect it to work, but is that what people are doing?

Using win 11 here .. no working
No work on my phone also .. android

1 Like

You really can't blame Hubitat for this - most home networks rely on the DNS service baked into the ISP provided router. Some are better at adhering to standards and being a local DNS server than others.

I have a C8 and a C7 setup as hubitat.local and hubitat2.local with reserved IP address each on my router, and they are in an IoT VLAN. Devices in my primary network can access devices in my IoT VLAN, but only my 2 Hubitat Hubs can access my primary network from the IoT VLAN.

Even with all this, I can access them without issue from Linux PC's and Mac's via the DNS name.

EDIT: turns out it's a Windows Issue - I thought it worked on Windows for me, but I was wrong.



edit: It also works on my Android phone.

Hubitat is named Hubitat. ninthhubitat.local does not work for me.

My router in an Ubuquiti edge4. This has worked fine in previous hubitat versions.

I thought I would have a play after reading this topic.
I have 2 hubs, c7 and c8.
In the settings this is how I have named my hubs.
Running windows 11 and using chrome in a new window, if I type in c7.local, it takes me to my c7 hub.
If I type in c8.local it times out. Very weird.
It's not an issue as I always use the hubs ip address which is fixed on my router.
I just thought I'd report my findings. :man_shrugging:

1 Like

Same problem with Windows 10, and three Windows 11 boxes. Linux always works. All my other .local devices work on Windows and linux.

I doubt my $450 Ubiquiti router doesn't know how to do DNS properly.

mDNS has very little to do with DNS. And your router has almost nothing to do with DNS. For most, DNS is queried by practically all devices and that query traverses a router to get to the Internet, where it's resolved and that answer is returned.

mDNS is a local product. Queries are made by practically all devices TO practically all devices and responses are returned.

If you had dns-sd on your system, and it's standard on Apple computers, you could query all your local devices with:

dns-sd -B _http._tcp

which would return a list of all devices that support that service.

in my case I get a screen full of answers, including:

9:27:37.182 Add 3 4 local. _http._tcp. Hubitat NinthHubitat
9:27:37.185 Add 3 7 local. _http._tcp. Hubitat NinthHubitat

which tells me that "NinthHubitat" is in the "local" domain, therefore, "NinthHubitat.local" is resolvable. But I knew that already since I simply have to browse to it.

Said another way, IF a mDNS query is sent out, hubitat hubs will respond. If browsing to the correct .local name doesn't resolve, it means the query isn't being made.

1 Like

I've noticed that is you use Nord VPN or any other VPN, honest doesn't work probably even if the location in the VPN is the closest location to your real location.

I do not use a VPN.

Did you try the queries that @csteele suggested? Might be interesting\useful to see the result.