Hubitat Elevation not Visible on Network

I purchased my HE C4 a couple of years ago. When I first got it, I started setting it up, but never finished. It's just sat in a drawer unused until now. Since then, I've upgraded my WiFi to a mesh system and my entire Network was reconfigured. Fastforward to today, I would like to prepare my hub for resale, but am unable to access it to perform a factory reset. When I connect it to the Network via the Ethernet connection to my Ethernet switch and power it on, the light turns green for a second or two and then turns blue and stays blue. I've tried both and and nothing shows up. I check my networks connected devices and the Hubitat isn't there. I'm obviously missing something, but I'm not sure what it is. Any suggestions would be great!

are you able to log into your router to see if it's getting an IP address?

IIRC Blue LED on a C4 is the fully loaded and operational status. (Equals green on the C7)


That’s correct. The C3/C4 hub’s only have Red and Blue LED colors.

1 Like

I'm using Nest Wifi connected directly to my incoming internet signal. When I go look at what devices are connected to my network through the Google Home App, the Hubitat doesn't show up.

You are correct, I misspoke in my OP. The light turns red when first plugged in and then goes right to blue.

1 Like

Could try opening a command prompt and typing arp -a. That should give you a list of all MAC addresses and their associated IP addresses. Look for the MAC of the hub in the list.

I tried your suggestions and the returned list didn't contain the hub. I've confirmed that everything is connected correctly. I originally configured this through a Fios router but have since ditched that router for the Nest Wifi. The Network name was something completely different than what it is now. Could this be the cause?

Are you plugged into the router or using wifi? If using wifi, might want to see if there is any difference if you connect via ethernet.

It's a wired connection directly from my laptop to the switch that the router is connected to.

You might try another Ethernet cable.

Try connecting directly to the router….

Another method that sometimes works is to use:


1 Like

I already did, lol. I'm baffled.

Unfortunately, I can't connect the computer and the Hubitat hub directly to the router. The router only has one Ethernet Port. That's why I use the switch.

I’ve heard this situtation before, just need to find the thread with the solution - something about the way the switch was configured….

I tried http://Hubitat.local and it just said page not found

What type of switch are you using?

It's a Linksys 5 port unmanaged switch.

I just dug my old router out of the shed and hooked it up with my laptop and my Hubitat connected via ethernet. Oddly enough, I still am not seeing the hub on the network.

Are any of the switches POE capable? Do you see my lights on the network connector on the hub? Just wondering if the hub’s Ethernet port might have been damaged?

The Network light is on, but I'm still thinking it might be a bad Port on the hub. Here's where I'm at. To simplify things, I pulled out the old router and connected just the HE hub and my laptop to it. Those are the only two devices on the network and the hub still isn't being found.