Hubitat elevation c7 firmware update stuck

got my shiny new hubitat c-7 but first impressions are far from the best. the UI is lagging, roaming between menus takes sometimes 5-10 seconds, and on the top of everything, update stuck as below (seems endless loop, nothing happens)

Currently running version:

Checking For Update

read couple of threads about the same issue but found no solution.

  • I have a mikrotik crs109 router, lan port is set to 100M fix (and tested also with 100M full / 100M half autoneg, issue is the same. Tried also the hubitat enable autoneg parameter , still slow like hell)

  • tried other ports, other cables, still slow.

  • using DHCP reserved IP address for the device.

  • the device is discovered via the portal[.]hubitat[.]com if I specify its ip address and

  • I can access the device on :8081 so I've tried both soft and hard resetting it, not luck. slow, firmware not updating.

  • my location is EU/ Ireland so its not easy to just send back the device.

  • tried the firmware with multiple browsers, firefox, brave, safari, all 3 on both linux and mac, same issue. ui is slow, firmware update cannot be found.
    the router have full access to the internet, but of course no port-forwards from the internet to the router.

any help is appreciated.

There have been some issues trying to get to 2.2.5, most were resolvable but some required intervention from HE staff. Have you put in a support ticket yet? @gopher.ny and @bobbyD monitor the forums pretty close, but there are a lot of posts so sometimes they miss one for a while.

1 Like

hi @thebearmay . thanks much for the superquick reply. I've been mailing support but dunno how to actually open a support ticket. is there a menu for that in either the community site or can be done from the hub's ui ?
thanks much.

Email should get through to them and are generally answered pretty quickly (may want to whitelist for your email if you can to make sure their answer doesn't go to spam). I copied them on my response above too, so if/when they're logged onto the forum there will be a flag for them pointing back here.

be my guest for a beer if you're in dublin! thanks!


Slow (consistently, same time between pages) UI means the hub is not getting out to the interwebs.

Setting autoneg parameter requires a tool that needs to get downloaded first, which brings us back to no internet connectivity.

Can you try page? There are a few basic network utilities accessible from it, that can help pinpoint the issue.

hi @gopher.ny so seems:

PING ( 1250(1278) bytes of data.
1258 bytes from icmp_seq=1 ttl=57 time=51.9 ms
1258 bytes from icmp_seq=2 ttl=57 time=13.4 ms
1258 bytes from icmp_seq=3 ttl=57 time=16.5 ms
1258 bytes from icmp_seq=4 ttl=57 time=10.2 ms
1258 bytes from icmp_seq=5 ttl=57 time=10.9 ms

--- ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4007ms
rtt min/avg/max/mdev = 10.194/20.573/51.928/15.831 ms

but it can't ping the gateway and can't do the speedtest.

--2021-03-22 19:22:23-- http:// speedtest . wdc01. softlayer . com/downloads/
Resolving speedtest . wdc01 . softlayer . com... failed: Temporary failure in name resolution.
wget: unable to resolve host address 'speedtest . wdc01 . softlayer . com'

so seems you're right, it can't reach out to the internet.

Can I please set static ip / dns and gateway for this device? I've been using DHCP and reserved the address but seems its not working. I'd like to set the network fully by hand.

ok. so I think I'm one step closer to the solution. I was just removed the reservation and led it to use simply DHCP for now, now pulling the upgrade. as I read, the up to date version allows setting network parameters by hand. so let's see! thanks much for your help!

1 Like

so the solution:

  • set DHCP by default , don't reserve the address,
  • upgrade the firmware
  • set static IP.

this thread can be closed.
Thank you @gopher.ny