Hubitat dashboard unresponsive when alot of commands are sent to my Zwave devices

I several aeotec devices around the house.

each dongle can control a set of lights.

I have some rules set shown below.

  1. at sunset, turn on 3 dimmer light circuits
  2. Dashboard has a macro button that when pressed turns off all 8 dimmers in the house

When hubitat sends a batch of commands, I noticed the dashboard becomes unresponsive. Press a button and nothing happens. It stays like this for a minute or so, and then it becomes responsive.

Issue doesn't happen when I have single commands. Only occurs when there is alot of signals sent by hubitat at the same time.

How do I fix this? its quite annoying when it happens.

Thanks all

I'm sure the first thing everyones going to want to see is a screenshot of your z wave details page. This will indicate whether you have any 'ghost' devices that are playing havoc with your mesh and also highlight devices with multiple route changes etc. Post a screenshot of that as the starting point. It's at Settings > Z-Wave details. If it won't fit on one screen, just do several screenshots.

Edit: Also regarding your macro button....if you create a Group containing all 8 dimmers, you could have the button turn that group off, rather than 8 individual devices. The benefit of that is that there are some options in the group for 'on/off optimisation' and 'metering' which can help. I believe metering separates out those multiple off commands, so that they're not all sent exactly at the same time.

1 Like

Thanks for reply John.

See the zwave details page here.

https://imgur.com/a/8NSHxPT

Another thing to make sure of, assuming you are using a C-7 Hub, is to update the Z-Wave Radio Firmware. To do so, go to the Z-Wave Settings page, and click the "Firmware Update" button if it is visible (see image below.) If it is no longer visible, then you probably already updated the firmware of the Z-Wave radio OR the hub is running an older version of the Hubitat Hub platform software.

https://docs.hubitat.com/index.php?title=Z-Wave_Details

I dont think I have C7 hub. I cannot see the buttons you see.

Check out https://imgur.com/a/8NSHxPT

I'll add more details.

The "All off on stairs" virtual button. Upon tapping it on, it auto turns off after 2 seconds.

Button details below
https://imgur.com/a/raPza5W

Below is the rule that auto turns off all lights and turns on stairs.

https://imgur.com/a/ERpz91T

Please provide any links on how to do this group metering thing.

It is in the Hubitat documentation for the Groups and Scenes app (linked below). You should enable metering, and to start with, set the meter to be ~250 ms. If that works well, gradually decrease it until the Dashboard issue returns.

https://docs.hubitat.com/index.php?title=Groups_and_Scenes

Check your apps list and if you've not got Groups and Scenes, select 'Add Built in App' at the top of the screen and then scroll down to Groups and Scenes to install it. Once installed:

  • Click the link in the apps list to open the app
  • Select "Create new group'
  • Add all of your required dimmers to the group using the 'Select Dimmers....' drop down
  • At the bottom of the same screen select 'Enable metering?'
  • Click Done

Then just amend your rule that does the 'all dimmers off'. (deselect all of the individual dimmers and add the group you created in its place)

metering of 250ms, wouldn't that be same as just putting a wait of 250ms after each command in my current list of "actions to run"?

I think you can only put a wait time of hours, minutes, seconds and would not be able to set a wait in ms.

Download the Hubitat app