Hubitat Crashes - About Same time every night

Hub crashes and seems to happen every day at around 00:55, these are the last log entries before the hub crashes. Can you help at all ? I don’t have that many devices attached – 11 Zigbee / 2 Zwave and the rest through Alexa integration

I have removed all apps and drivers so just back to basics, and done a database backup - soft reset and restore and is still happening.

As I have so few devices I am wondering if I should do a hard reset and start from scratch ?

Thank you.

My Hub is a C7 running 2.3.4.114

dev:6362022-11-26 00:55:21.102debugbasic 255

dev:6362022-11-26 00:55:19.617infoLanding Radiator - Parsed SwitchMultilevelReport(value: 0, targetValue: 0, duration: 0)

dev:6362022-11-26 00:55:19.357infoLanding Radiator - Parsed SensorMultilevelReport(precision:2, scale:0, sensorType:1, sensorValue:[7, 57], size:2, scaledSensorValue:18.49)

dev:6372022-11-28 00:53:10.222traceBedroom Radiator - POLL [BatteryGet(), ThermostatSetpointGet(setpointType:11), BasicGet(), ThermostatSetpointGet(), ThermostatModeGet(), SensorMultilevelGet(), SwitchMultilevelGet(), BasicGet()]

app:422022-11-28 00:50:00.076infoCircadian Daylight (Circadian Daylight): The current mode is not set for an override.

@bobbyD

How do you know it crashes?
Does it reboot itself or is the web interface just inaccessible the next morning?
What is LED color?

How are devices connected through Alexa integration? Virtual switches?

You could check this endpoint as well to see if there increased hub or low memory leading up the issue. HUB.IP/hub/advanced/freeOSMemoryHistory

4 Likes

Web interface is inaccessible. Light is green. About 35 devices through Alexa, thanks for the steer on memory. Happens to me too as I get older...

Did this only start after updating to 2.3.4.114?
Have you tried getting to the diagnostic tool when it is locked up? Usually the diagnostic tool is still running.

You can roll back to the prior firmware using the diagnostic tool as well:

2 Likes

I wouldn't take such drastic measures unless you have a good reason for it, like removing newly added custom integrations that appear to have caused problems. Removing built-in apps and drivers is rarely an effective measure of solving hub problems.

Did you happen to notice when the web interface is not accessible, if the Diagnostic Tool is also not accessible? If the Diagnostic Tool isn't accessible, then that is indicative of a network issue. A daily recurrence around the same time, may also be indicative of a network problem, such as conflicting IP address within your network.

2 Likes

Based on the above logs, it doesn't look like you removed all apps, the Circadian Daylight can get very chatty is it's misconfigured. Have you tried removing that app to see if your experience improves?

1 Like

No was unresponsive on the previous two versions of the software. I should say when I have removed superfluous software, I mean apps that were not installed as part of the hubs core apps. Until I read earlier that the diagnostics were usually available I hadn't realized so will try that. I am kind fo thinking though for the 1hr that it will take me to add back all my devices - do I just do a full reset and cut out hrs of fault finding...

It is highly unlikely that your devices are causing the problem, so I wouldn't go the route of removing them. Rather, I would remove (disable) heavy apps that have the potential of going rogue.

3 Likes

Curious myself, you mentioned disable. Would clicking the X at the top of the apps page and then checking the apps on the side 'disable' them for this test or do they have to be deleted? May save some time and frustration if there is a lot of configuration into an app.

2 Likes

Yes. Disabling apps and/or network connected devices saves the time of removing them when troubleshooting issues. Disabling mesh connected devices is not an effective way of troubleshooting, as devices remain connected to the radios, generating traffic, even though the events are not posted on the hub side.

7 Likes

I too am still having this same issue. The hub dies every day at about the same time around midnight. It is no longer accessible on the network. I have rebooter installed and it works if I set the time before the daily crash. If I schedule it after the crash, it does not run. Seems like the entire OS just hangs as nothing executes when it happens??? The only way to recover is to cycle the power to the device.

Have you tried the above suggestions to try and narrow down the problem?

1 Like

Can you post a screen shot of your logs around that time?

Try setting your Package Manager update time to something else like 2AM, see if the crash shifts to that or stays at midnight.

Also, if you can configure the Konnected discovery time, maybe change that as well. Not sure if it just runs on a schedule or how often it goes?

1 Like

I've never seen HPM hose a hub before but @jtp10181 suggestion is spot on. there's a first time for everything! And just to clarify... you manually restarted the hub sometime between midnight and 6am?

I also wonder if you've experienced some database corruption because you've had to hard boot the hub so many times. At some point (maybe after following Jeff's advice and going through one 24 hour cycle) you might want to do a restore from a recent backup. The restore process does a soft reset and cleans the database.

Yes, I am manually power cycling the device every day when I wake up.

I changed HPM to 2 mins in the future and it ran without issue. I do not see a way to configure the Konnected discovery time.

I have also already tried a restore from a recent backup as one of my troubleshooting steps.

Will report back tomorrow after the next Konnected discovery job runs.

What is app 243? Shown getting an error right at the bottom of your screenshot.

Good catch... that looks a bit like a network connectivity error trying to reach 192.168.1.122. Though I think HPM would cough if it couldn't make a network connection either.

Download the Hubitat app