Hubitat C8 Unresponsive, C8 Locked Up, C8 Frozen,

MTU below 1500, ethernet. Green Light. Stable power.

Apparent random lockups, no IP access to Web Interface, Pings unresponsive.

I feel like this is under-reported and is a serious flaw in C8. I am also posting on Reddit, same comment title under "C8 Problems" thread and perhaps elsewhere with a new post, same title as here...

Not sure why a "serious flaw" would be under reported, that's exactly the type of problem that does bring folks to forums to get help. :slight_smile:

What's the frequency of this occurrence, is this a daily issue for you, or ? If you've been pulling power to reboot the hub when you can't get to it, it's possible there may be some corruption of the hub database...have you tried a soft reset?

1 Like

This is the official channel to receive support, and they will just direct you back here from Reddit. I would stick to one place (here) so everything is handled in one place and one thread.

I don't think that the C8 is having any more issues than any other series hub. There seem to be a handful of people experiencing lockups. It typically is either a networking issue, or some cloud based integration.

Maybe start with looking at any errors or warnings in your logs tab. Also Device Stats and App Stats in the logs tab can help pinpoint some issues.

Also, what color is the LED on the hub when this is happening? Can you access the diagnostic tool when this lockup happens? Hubitat Diagnostic Tool | Hubitat Documentation

This would be a good thing to try, and it is completely safe to do. As noted, if you are pulling the plug or if you experience power outages in your area, this could have caused corruption in the hub at some point.


Thank you. I am a little skeptical, perhaps paranoid, about support forums, I see a disturbing trend of "curating" feedback. My apologies for suggesting that about this community.

Reboot by switch port PoE solves problem temporarily. This is on the same setup as with the prior C7. PoE splitter on Meraki Switch. This is all over the net, C8 unresponsive. These brick with alarming frequency.

I will say that I suspect there may be some connection to the Homekit integration... this is arbitrary, solely based on the fact that other posts from almost all other sources seem to include the native Homekit beta integration.

I will also say that other than this, all is well.

Thank you.
I am not feeling the network issue base on packet capture info./ hubitat logs
I am looking into logs for cloud integrations (Kasa and Ecobee only) and will follow up with the suggested steps including diagnostic tool.

Maybe try not using the POE splitter temporarily? I have seen some people have issues with them.

I haven't seen any evidence that there is a fatal flaw in the C8. As users we don't know the true story of how many hubs die, but this forum would have been absolutely bombarded with reports of it if this was true. Like I said, there are some users with issues, but not on a grand scale.

1 Like

Content/people aren't "curated" here...if they were I would have been banned years ago. :wink:

This type of hard reboot isn't good for the hub, could result in database corruption, so you should start w/a soft reset (basically downloading a local copy of the hub database and then restoring it - the database is "cleaned" before downloading.

If you can, as @neonturbo suggested, get content from your logs near to the time you experience the lock-up, that can help figure it out...

How long has this been going on, and how frequently?

1 Like

Frequency is 1-2 times a month. Not a lot, but enough to think theres a problem. I have performed a soft reset, but... we DID have a power issue last week (Vermont) so there may have something there.

This happens without those issues normally, I have a hardened network with UPS and I feel it's very unlikely it's an integration.

How is Hubitat handling unplanned power resets if its so susceptible to unplanned reboots?

1 Like
  • Curated... dude. Apple has me losing my ■■■■. I am sorry.
1 Like

I am not thinking "grand scale" or "fatal" bro. lol I have SOME patience! I think it's happening too much with C8... and less with C7... anecdotally... My C7s were solid AF and Never bricked after power outages and thats for many years at a time, in about 5 locations around the earth.

It handles it as well as it can, but there is a risk when a reboot is performed w/out a proper shut-down.

When it's unresponsive are your automations still functional? Lights turning on w/motion, button devices working, etc.?

If you have a repeating issue w/your C8 hub going unresponsive you may need help from the hubitat @support_team.

1 Like

with the kind of power cycling you're doing you should do a soft reset to ensure you don't have a corrupted database. Also have you been tracking free memory at all and seeing how low it's been getting?


Can you PM your hub id to the @support_team ?
We can check the engineering logs on the hub.
Also, what is your router?


Cisco Meraki Stack
MS250 MTU ≤ 1500

@danabw - Zero Functionality, this is how I know its unresponsive. Totally Bricked via Homekit... unresponsive to webUI BUT... I feel like once I tried the official Hubitat App and it worked to switch zwave lights? Cannot verify, I feel like I wouldn't overlook that... unresponsive means unresponsive as in totally unresponsive. All I gotta do is wait... It'll brick again.

I will send requested info to Xsupport_team soon.

1 Like

When it was locked up did you try going to yourhubip:8081 from a desktop browser? Also what comes back when you ping hubitat.local ?


I'm also having this issue with someone I set a C8 hub for:

  • C8 hub connected via ethernet.
  • DHCP.
  • Auto reconnect is set to 60 seconds.
  • The hub completely drops off their network. At the router level, it no longer sees the C8 hub.
  • The C8 hub has to be unplugged and then plugged back in.

To further throw things into the mix, there's a second C8 hub on the property connected to the same network with the same connection settings. I've had zero issues with this hub.

EDIT: I sent a message to support to have them check it out.

I'm having the same problem. Once a week or so my C8 hub hangs and stops responding. No automations run, both the main web server and the diagnostic tool are unreachable, no response to pings either. I have done a soft reset and restored from backup but it is still happening. Any ideas?

disable all lan integrations and watch memory consumption. If things stableize, re enable each lan integration one by one till you have an issue.

1 Like

The only integrations I have are Hue and HomeKit. I can disable HomeKit but the hub is useless to me without Hue integration.

Current men usage:
Date/time,Free OS,5m CPU avg
2023-07-30 19:18:52,562392,0.77

Use @thebeatmay's hub information driver. Are using the built in hue or cocohue integration?

Download the Hubitat app