Hubitat C7 with Zooz Zen77

I'm in the process of setting up my C7 hub (FW 2.2.8.156) with the following Z-Wave switches:

Zooz Zen77 (30+)
Zooz Zen30 (6 for bathroom exhaust fan/light combo)
Leviton ZW4SF (4 for bedroom ceiling fans)




I've been fighting with the C7 hub to include them and it's insanely frustrating. Sometimes SmartStart works. Sometimes it says finished but the device doesn't show up in the device list. Manual pairing/inclusion doesn't work half the time for either brand. I keep having to do it repeatedly. About half of the switches were included without issue the first time but the other half no chance. I have this list of switches in the Zwave details list (ghost devices) I can't remove (hangs/freezes), don't show up in the devices list, and can't repair. For devices that were included but with problems I can't exclude nor force remove (error 504 or something like that). If I try to go back through the inclusion process it just says failed or doesn't show up when manually including them instead of using SmartStart. In addition to ghost devices I'm getting random unresponsiveness or lights shutting off (especially with the zen77), can't exclude devices, can't force remove devices, and the list goes on. At this point not sure what to do, tried repairs after repairs, numerous reboots with power removed, etc. Had the occasion issue with my C5 but I was generally able to fix it but with this C7 it just refuses to work properly. Ngl, feels like C7 wasn't ready for primetime.

The best advice for this kind of trouble is:

  • try to get rid of "ghost" nodes or "stranded" nodes that may have resulted from failed pairing attempts; it sounds like you have many. It is normal for the UI to hang a bit when you hit "Refresh" in Z-Wave details, as it tries to ping the node. If it can, it will not get marked as failed, and "Remove" will not appear. You will usually need to remove power from or reset the offending device to help this process.
  • try shutting down the hub (from Settings > Z-Wave Details), then unplugging it after the LED turns red and leaving it unplugged for at least 30 seconds before plugging it back in. This will allow the Z-Wave radio to restart, which is not affected by a "regular" hub reboot, and it could help with some of those "busy" messages in your logs (or certainly with a Z-Wave crash, though I don't see any of those). Also, try not to do two things at once--e.g., wait for inclusion and initialization to finish before trying to exclude or include another device if doing manual pairing. I don't use SmartStart so don't really know how this ties into that.
  • if using traditional (non-SmartStart) inclusion, you may need to reset the device and/or do an exclusion after a failed pairing attempt (and make sure any failed attempts are gone from the Z-Wave table, too). Again, not really sure how SmartStart handles this...
2 Likes

I have only tried Smartstart a couple times, but from what I remember it was slow. In other words, you did the scan, plugged in the device, and it took minutes to get it into the hub or at least to see it on the Zwave page. If you are expecting instant inclusion like the old-fashion include button, it doesn't seem to work that way. Not sure if this is normal or what, like the meme goes "ain't nobody got time for that".

It does appear you have many ghosts from failed parings. It looks like everything in your picture up to the back porch fan is a ghost. Not sure what everything else looks like, you probably should include all your Zwave details.

@bertabcd1234 gave you some good advice above. I would do like he says especially regarding the ghosts.

I have also had better luck with the ghosts if you do a reboot between removals, or maybe every couple removals. Hit the discover button, remove, and wait for maybe 1-2 minutes then reboot. And maybe try removing again after the reboot if the ghost persists. I don't think this is "by the book", but like I said some of these can be stubborn so give it a try if the correct way fails.

Removing ghost nodes is one of many problems, simply put I can't. I've tried several methods to include the shutdown method you describe with no luck. To make matters worse several of those nodes show neighbors which tells me they aren't really "ghosts." One ghost node with 13 neighbors I was able to get to repair and discovered (added to the device list) but the other 2 devices that show neighbors fail every time. Devices with only 1 neighbor are truly ghost nodes but even the ones I know that aren't I can't get to exclude even after resetting device.

@neonturbo Unfortunately I'm familiar with the time it takes for SmartStart to work and for me it's often more than just minutes. SmartStart so far has done better with in a way forcing the hubitat to include the device because manual inclusion (and even exclusion) has so far yielded no results. As in despite the hubitat and zwave device being in inclusion mode, the hubitat refuses to see the zwave device. I also agree with the reboot between inclusion/removals. I have realized the same but it didn't work every time.

I recenty had similair z-wave inclusion issues, and I am new (3 weeks) to HE. I am coming from SmartThings. I had 15 or more failed attempts in the z-wave details and could not get them removed. Finally I powered off the ST hub and the HE hub (unplugged as well). Then after 30 minutes I powered on HE, waited 10 minutes and then went into z-wave details. What worked was to hit refresh on ghost then remove when button appeared. If it did not remove the status would be PENDING. I would hit the remove button again, and if failed, again until it removed. Most took at least 3 or 4 tries to work. I only hit refresh once, and then repeated removes once page was done. The important thing here is NOT to move to any other entry. Stay on the one you are trying to remove. Jumping around always failed and forced another HE hub shutdown and wait.

Hope this makes sense and helps you out. This worked great for me. I then was able to reset the ZEN30s and get them added with no more issues once all ghost were removed from z-wave.

I also have both hubs up and today added 2 more z-wave devices to HE with no troubles. I also have found sometimes you have to be closer to hub and once moved to where you want them wait a couple of days for the mesh to settle in.

I noticed the same thing about several attempts. While I did get the majority of the ghost nodes removed the nodes that show more than one neighbor still won't come off. Makes me think they aren't actually ghost nodes but real nodes, except, there aren't any that haven't already been included. These nodes show neighbors, can't be removed, and there aren't any extra switches connected that I'm aware of. I'm at a loss as to what they are.

Can I return my C7 yet?

2 ghost nodes that refuse to be removed. They act like they're still connected to a node but there are no nodes/devices installed that haven't been added to the Hub.

Despite numerous power downs/unplugs, repairs, etc i continue to get parsing issues.

Constantly getting incorrect reporting events. Constant random actual events like lights shutting off or turning on on their own. As an FYI the only rule currently active is with Rule Machine and only involves 2 lights. With as unreliable as this thing has been I haven't had a chance to create more. Probably because i don't even have all my switches installed because I'm still messing with the stupid hub. At what point do we say it's the Hub???




There is no doubt that zwave can be finicky - especially on any hub using the new zwave 700 chipset. The pairing process is the most troublesome. I paired another 20 devices last week, and had the normal issues I expect at this point - with the most common being the pairing not completing 100% requiring hub reboot and then "discover" button on the zwave details page, etc. It is a pain.

That said, once paired it tends to work very well. I have 95 devices on my C7 right now, working perfectly - including 1 Zooz Zen77.

So, while it definitely CAN work if you make it through the pairing pains, only you can decide if it is worth the time to do so.

If you decide it is not, I would suggest you try a hub with a zwave 500 chip, not a 700. A lot (My guess is actually "all" as far as I can tell based on the multiple zwave 700 hubs I have) of the pairing and removal issues are on other zwave 700 based hubs as well.

Good luck!

1 Like

I had the C5 for several years with numerous switches from different manufacturers (GE/Jasco, Inovelli, Zooz, etc) and I rarely ran into issue associated with the hub once paired as you described. I sold that house earlier this year leaving it behind and used the new house as an excuse to go full sweep 700 series - so far huge mistake imo. That being said, I've repaired, for the thousandth time, several switches and all are working at the moment. No doubt come tomorrow or later tonight one or two will no longer respond (the garage light seems the likely candidate). Hubitat staff also said ghost devices, if they don't respond, are supposed to fall off by themselves after a day but so far that hasn't happened. There are still 2 ghost switches I can't remove. I have them both in "pending" status hoping that will force it to fall off by tomorrow but I guess we'll see. I'm going to be annoyed (not that I'm not already) if I have to end up getting a UZB stick to clear them.

Well, a $20 UZB stick is worth a lot less than dozens of hours of my time. So it was an easy decision to buy one for me.

Should you "have to"? No, of course not. But it is what it is.

4 Likes

You're not wrong but there's still the shipping time. lol

1 Like

Usually the reason ghost node won't/can't be removed is because the device that caused the ghost is still powered on. So try this

Disconnect/remove power from the device(s) that you suspect

Shut down hub from menu and unplug at wall for 5 mins (this will clear the z-wave radio, don't disconnect from hub side)

Power unit back up.

Go to z-wave settings and start clicking refresh on device(s) that you want to remove until the REMOVE button comes back up. You may have to click refresh several times.

Let us now how it worked out!

1 Like