Hubitat C7 with zooz switches

Ok, completely new using Hubitat and zwave devices, so I apologize if this has been discussed but I did search and checked quite a few posts. I just installed the first devices into my habitat a couple zooz switches, zen22, zen26 and one zen30. Everything looked ok with the z22 and z26 switches, I was able to check their status from the devices page and turn them on off directly there. for the zen30 was a nightmare to added it to the hub, I wasn't able to put it in a pair mode and when I finally did it was added as a generic device with no type (I though hubitat had already the driver for this switch). Now none of the switches work. I see their status if I click them physically they work and status change but I am not able to turn them on/off from the device section neither from the dashboard, where I see them as a button but nothing happen if I click on them. Earlier I was checking the zwave details and I was able to see my devices but now if I go there is empty. Am I doing something wrong, should I expect all this issues from a zwave devices? I will really appreciate any help.

This is an odd problem, indeed. Try powering down your hub: Settings > Shut Down from the admin UI. Leave it off for about 30 seconds or more, then unplug and plug back in the power adapter to restart (I'd prefer the wall side given that some people have bad luck with the micro-USB connector, but technically anything will work).

This will totally shut down both the hub and your Z-Wave radio, hopefully doing a full power cycle on the latter. There are a few problems staff are aware of with Z-Wave in the current public release, and this relieves it for some. Hopefully it helps, and hopefully you won't have to do it again! (At least after the fixes.)

Just to be sure, did you go into the device page for each switch and ensure that the right driver was selected from the drop-down for the switch, and then save and hit the Configure button to update the switch?

Hello. Yes, z22 and z26 switches were paired correctly as Zooz Central Scene dimmer and Zoooz Central Scene Switch, which i think is correct and they were wokring fine, I was able to see their status and control them from the device page. Zen30 switch was a different story, It was a hell to pair it to my hub. I wasnt able to put the switch to pair mode or exclusion mode no mattter what I tried until finally got into pair mode and was added but it was added without any type so I gave him the Basic Standard Zwave tool, but the device hasn't reported any activity at all since it was added and I couldn't even see its status.

After all this, I noticed that the other switches were not responding anymore to the on/off command from the device page and the zwave radio devices page is blank now when I used to see my devices here. The other switches still report their status fine but I am just not able to control them from the hub just physically

That would be a problem.

The Basic ZWave Tool is a TOOL. It's a driver that allows you to send arbitrary ZWave commands and Query the ZWave device to get back data. It prevents the device from operating in it's normal manner.

When a device Joins/Pairs (ZWave/Zigbee) and it results in a driver selection of DEVICE, that simply means it's a device that isn't recognized from the hundreds on known devices and the Hub doesn't know what Driver to assign. You did right in assigning on, but did pick one that is exactly the opposite of what you want.

Try a Generic ZWave Switch OR try the Zooz Double Switch

Screen Shot 2020-08-22 at 9.34.06 PM

Thanks, I tried as well with both Zooz double Switch and Generic Zwave Switch but still the same, I now see a lot of options but none of them works or do anything and switch still doesn't report any status

This is with Zooz Double Switch.

this is from one of my zen22 switches. They at least report the latest state but commands don't do anything at all. Commands used to work when I just installed the switched but after I added the zen30 something happens and now none of my switches respond to any command from the hub

Did you do the shutdown outlined by bertabcd1234 above?

Often if the Zwave has stopped for some reason, the shutdown, pull power for 30s and power back up seems to fix that. A simple reboot doesn't work, nor does not pulling the power.

It looks like you understand the Hubitat way.. but just to be sure.. you did click the Configure button with each Driver change, correct?? That's two button presses, Save device to save which driver, and Configure to send a set of configuration parameters from the Hub to the device.

For lurkers, the reason is that modern devices have 17 to 200 "parameters". Some are for simple things like LED On when the switch is OFF or vise versa. However, multiply up the number of parameters and effectively we each buy 4,000+ devices inside one physical device. The Driver wants to talk to ONE of those 4,000. :smiley: Clicking Configure has the driver send, one-time-only (with each click) all the parameters with the correct values as defined by the developer of the driver, thus causing the device to match the Driver's expectations.


@eoga ... I have the Zooz Double Plug and have confirmed with Zooz support there is a issue with the driver for this device when used with the C-7. I would recommend you contact Zooz support and see if your problem is related to mine.

1 Like

ok, one of the issues has been fixed with the hard reboot now the other switches z22 and z26 are responding again. I really appreciate the help of @bertabcd1234 and @neonturbo. I have rebooted the hub but not pulling the power for +30 sec, I am guessing zwave is kind of special.

About the zen30, @csteele I didn't know I needed to click on the configure, I guess I learned something new today, I thought clocking on Save device was enough. Now I see in the logs that something is happening but it keeps telling me that there are 22 pending changes and that I should click save again but nothing else happen but again it show that 22 changes are pending.

Now I see a Zen30 child, not sure what is this for, and last activity.

As well I see now that it report 2 buttons and current state, although i thought it would report 3 buttons as this is a double button switch, the normal on/off (two buttons), and the fan button.

Everything starts looking better and I guess I am learning more but this switch, zen30, still doesn't respond to any command or shows the correct state. Am I still missing something in the configuration?

thanks for the information, I will definitely contact zooz support to check what you just mentioned.

Glad it is partially up and running again.

Many (all?) fan controls have at least one child device. I think that is pretty normal to see, although I am not familiar with this exact device.

I suspect there is one of a couple things going on with the Zen30. Either this is one of those C7 quirks where it won't work until they fix whatever is broken, OR your mesh is weak to where this isn't reliably communicating with the hub. I don't have a suggestion how to fix it exactly, but it might be worth (temporarily) moving the hub close to this switch, and see what happens. Be sure to do a controlled shutdown if you do move the hub (no pulling power cord!).

Now I am getting below status for my zen30 switch in the zwave details page. All the other switch are Ok

First I got

and now


That makes me think even more that you have a mesh issue. Do you have a fair amount of Zwave devices, in particular line powered (repeating) devices and/or dedicated repeaters? I don't know the magic number (if there is one) but it seems like for an average house, it takes about a dozen or so repeating devices to get a basic Zwave mesh, and more is better.

1 Like

Zooz don't make z-wave stuff for the UK market, do they? I have been looking for some as they seem popular.

Should there be a feature to "auto configure" after a driver change?

I wouldn't think that I have a mesh issue, at least not cause by distance, if any then I would think that it is being caused by the zen30 switch. This switch is the closest to the hub only 1 meter (3 feet) away from it and it is the only one that still hasn't responded. I have tried to start the exclusion process on it but it is pretty hard to start either pairing or exclusion status on it, it seems like it wouldn't recognize the 3, 4 or 5 clicks. The first time I tried to pair it was the same I got it in pair mode after more than 20 attempts. I will see what Zooz support mentioned once they answer. I have heard their support is really good answering on time.

I totally agreed, especially for new people to Hubitat. I would have thinking that after changing the drive and clicking on save the changes would have been applied automatically.

1 Like

That certainly seems like it would support the most common use cases - I'm changing my driver and want the device at least initially configured, and 1) I don't know that I need to tap Configure, or 2) Oops, I forgot to tap Configure.

Users who are more advanced should not be bothered by an auto-config - they'll still be able to get the device setup however they want.

I guess for now I'm on the fence a bit... if I had to pick though, I think I'd come down on the "no" side. When you change a driver, often it's to get new/different features. I'm thinking about the Aeotec MultiSensor 6 driver I maintain. When you join the device, you get the Hubitat built-in driver, which is just fine. If however you find you want some of the extra features, you can switch to this Community driver BUT, doing so exposes all the features. Probably you want to pick some and configure it to your liking. In that driver's case, saving preferences also does the Configure.

I don't see how auto-configure could help in that scenario. And if it didn't help with the one example, it seems it extends to all driver changes. But as I said, I'm rather on the fence about it. An auto configure just eats Z-Radio without noticeable harm. I've spent so much effort to 'protect my Z-Radios' I'm clinging to that idea still. :slight_smile: