Hubitat C7 hub no longer powering on

I use these... no issues. Only good for 100Mbps but that's all HE's ethernet port supports anyway.


They do make gigabit ones, but as you say that would be useless for these hubs

The connector wasn't salvageable, it was damaged internally. The traces and pads were also completely ripped up. The through hole connections were good at least. I ran some #30 to the next components in the line and added a new connector. Epoxied everything in place and it's booting properly now. Going to give it 24 hours for the epoxy to cure and then ship it back. Be careful with the connector going forward, even though it's been glued it's not as strong as a factory reinforced connector and there was some trace damage.


Life saver! Thanks again!


Hey my C7 died last night after I did a cold power cycle by removing the micro-USB power plug. I won't be home for several hours, but I suspect the USB plug somehow suffered some damage. It's an older C7, so probably no reinforcement. If I can get it open and inspect for damage, would you have cycles to resolder if the connector is toast? I do have Hub protect subscription and 99.9% sure I enabled cloud backups, but I'd prefer to have my current unit repaired if it has physical USB plug damage.

Thank you for being a Hub Protect subscriber. As I am sure you know, Hub Protect covers this type of accidents. If you didn't already, I recommend opening a protect claim by visiting the following page to get a free replacement (you would only need to cover the shipping):


I would highly suggest going with the hub protect service as USB port repair success highly depends on the damage to the traces and a bit of luck. The connectors don't take heat very well so you have to nail it on the first try per connector.


Thanks, I just got home and submitted a support ticket.

1 Like

Thanks! Hub protect cloud restore worked pretty well. Have another thread on here about my lingering z-wave issues.

@lewis.heidrick is your offer to perform the surgery on this still standing? I’m 90% certain I’m facing the same problem

happy to send pics before shipping anything.

hub details

device is in a power-less state right now so I can’t pull the actual data.

  • Model: C7
  • Purchase date: September 19, 2021
  • Purchased from: Amazon (not third party)

breakdown of the issue

  • The micro-usb housing seems super finicky for some reason
    • no drops or yanks and the unit has always been placed in a “safe” location.
  • Without taking the device apart afraid I might break something by opening it - the behavior of the power on and also the lack of powering on reliably indicates a faulty connection.
> also potentially causing issues with the Zwave radio

since 1/2 the time when I do actually get the device to power on, my Zwave table is empty whereas there should be about 15-20 devices living there.

steps to reproduce

  1. if I plug it in and create a significant ”downward” pressure on the connection - like putting it on a desk with cord coming from below, then laying something weighted on the cord and also something weighted on the unit to keep it from popping up - causing the usb to pitch upward into the housing, I can get it to power on.
  2. but if I move it ever so slightly or try to adjust the placement in any way, I lose the led, and the device goes offline,
    • and I will most likely lose my Zwave table once I get it to come back on.
    • the “trick” of fully unplugging the usb from the unit for at least 30s before turning back on, works almost flawlessly (for now)

polite ranting to follow:

I understand that this would be covered if I had the extra device warranty, and would gladly pay that for user damage, but I’m convinced that it’s not actually me this time.

**I would think that a manufacturing defect like this would be covered with or without warranty since it was corrected in a later iteration of the same model. **

It has frustrated me to a point where my next purchase for Zwave / zigbee control have been the usb dongles to use with home assistant.

  • At least this way if something breaks (like it has) unexpectedly, I can only expect to have to spend $30-50 for a new part instead of >$100 for a whole new hub to get my setup back up and running.

but I still like hubitat!

I am having a hard time setting up with home assistant - for automations that seemed pretty simple to make a Rule Machine app for, now I have no idea yet how to make that happen with home assistant.

Consistent with what other forums have stated they use hubitat and bring it into home assistant with the HACS integration. But I’d rather not have to buy a whole new hub, and also have a hard time supporting a brand that makes defective hardware and doesn’t do a “recall” or contingency replacement if the hub is identified as one of the defective units.

Lewis doesn't appear to have logged in in many months, and his last post was about a year ago. Not sure what his status is, but I doubt you will get an answer from him at this point. Would be nice to see him respond though!

You might try filing a warranty claim, even though you are out of warranty and see what support says. I am not sure that will get you anywhere, but worth a shot.

Anyone who is fairly proficient with a solder iron could probably fix this quite easily. I am not sure if there is someone in your area that repairs electronics, maybe even try a community college or something like that?