Hubitat C7 Freezes with past two updates

Hello,

New Hubitat user here where I’ve been using it to integrate my Lutron Caseta & Philips Hue lights (mostly for Pico switch use) and with the past two updates my hub freezes up after a short period of time (30ish minutes to an hour, maybe two) without fail in that button pushes run by the hub no longer control lights, and the hub itself is not accessible via local network.

The only way to restore function is to power cycle and reboot. So far I’ve tried repairing all of my community apps (CoCoHue and Dimmer Button Controller are the two I rely on), deleting unused integrations/apps, etc. to no avail.

Are there any logs I should be looking at for clues as to what is causing this? I love the Hubitat and how quickly and reliably it has been handling my light integrations, so it’s quite distressing to have it not working.

I’m hoping the next update might correct whatever is happening, but otherwise I suppose it’ll be time to just wipe this one and start fresh if we can’t figure out what is causing this.

Sorry for your troubles! I'm sure it's frustrating as heck. Let's see if we can figure out what's going on.

Have you tried reverting to the version before you started having the issues?

Probably a good idea to do a clean backup followed by a restore. This has the effect of removing any contamination from the database caused by an unexpected loss of power.

Sometimes there are hints in the logs - do you see anything from the time you had the issue?

There are probably less drastic ways to figuring this out!

Do you by any chance have jumbo frames enabled on the network segment to which HE is connected?

What does the LED do when this happens? Can you still ping the hub? And can you get to the diagnostics tool on port 8081 when the hub locks up?

Are the buttons you're using directly paired to HE or are they lutron picos or Hue devices connected to the Hue hub? Trying to figure out if HE is still up and running but lost network connectivity. If your buttons or lights are on a different hub it may not be that HE locks up - may just be a network connectivity issue. If you have something running entirely native to HE it would be interesting to see if that still works.

What does your network configuration look like?

2 Likes

recommend doing a backup .. take it off the hub.. then do a soft reset , then when it boots back up restore the backup.

2 Likes

BTW in more recent versions the restore actually does a soft reset, saving this step.

3 Likes

They're Picos running on a Caseta Pro exposed via telnet to the HE. Haven't seen anything obvious in the logs, but I'm not really sure what or where to look for either.

The hub isn't accessible via the diagnostic interface when it's locked, it seems to be fully non-functional. Jumbo frames were enabled on this switch, but I've since disabled them.

Now I've noticed something interesting, my switch was just showing RSTP blocking on the HE's port. Is it possible that a HE could cause a network loop? Trying to understand how that might take place. Otherwise a bug in my switch?

So it seems possible that it might not in fact be the HE freezing, but the switch disabling the port. I'll keep monitoring the switch port and see what it shows next time it becomes inaccessible.

Not sure how that could be since HE has only one ethernet port. You don't have a wifi dongle I take it? Even if you did I'm not sure how this could result in some sort of routing loop.

Can you disable RSTP on that port?

No Wifi dongle, so yeah I'm baffled as how to it could make a loop.

What kind of network gear are you using?

All Ubiquiti (router/network controller, switches, APs, etc.). Ubiqitui released an update and I disabled RSTP on that port which seems to have fixed it. At least it hasn't been knocked offline in 2 days now.

Hoping that fixed it for good, but it's still odd.

Well, still going offline. This time no RSTP error noted on the port. However since restoring the hub from a backup it’s lasted a day or two between freezes instead of an hour or two prior.

Any ideas on where to look next?

Me too. Have not had any issues with any of my hubs though. Wonder if that's a wild goose chase.

Can you PM me the hub id? I can check the engineering logs on the hub. It may have some clues.

1 Like