Hubitat C4 - not booting

hub does not show up

via LAN IP Scanner,
hub not showing up

via My Hubitat :
Hub Information
Hub ID:
IP Address:
MAC address:
Platform version:
Hardware version: Rev C-4
Last Checkin: 11/10/2023 - 13:24:16
Active?: No

When conmectinmg power the red light flashes briefly then no other lights at all

The switch LAN port it is connected to flashes fast and continuously (likle th eother pots that are connectred to devices)

Am unable to find the C4's MAC on the LAN

When the device worked it was uanble to update successfully, eventually it died - even after attempting to reset (was never able to find a full factory reset option)

I tried to send a support ticket but was unable to find where one does that, no email to contact, no online webform, i could not find any direct method to reach support. Thus why a public posr here in the forum. Sincere apologies if this is not the correct place for help.

Not being able to find the hub on the network, i cannot login to 8081

I have tried other power supplies and ethernet cables, no change, unable to see device on network or my.hubitat.

In old posts there is mention of a reset button atb the back of the AV port, pressed, held 30/30/30 - nothing changed. There was also mention of an old TF card solution to unbrick C4's but i cannot find any information or files to try this method.

What should I do next ?

Have you tried a different power supply? (never mind, I just saw you tried a different power supply)

Because the behavior doesn't change with a new power supply, the chances are high that your C-4 has died. If you purchased a Hub Protect extended warranty for your hub, you can make a warranty claim here:

Through the support portal:

I've edited your post to remove identifying information.

Ambassador Aaiyar, thankyou for the near instant response.

I presume my C4 is no longer under warramnty thus I did not send a message via the warranty web form. Which option on the page should I have used?

I was not really aware of the Protect hardware coverage option, I paid something in the past for remote access but I dont think I paid for Protect - which is unfortunate as I usually tend to pay extra warranties and coverage when available.

Would it be possible to try unbricking the device?

In the forums it's also mentioned that the C4 hub hardware is an unbranded x96 Mini11 with Amlogic2 S905W, is my only option to try install an android tv firmware ?


Not really unbrickable. If you can't ping it that means that the platform didn't load where you can even get to the diag page... :frowning: Do you have any backups saved locally?

1 Like

I was thinking through the TF card slot - as was done in the past before the 8081 diagnostic page was a thing.

It may be possible to dig out a backup if required else starting afresh is fine.

1 Like

I think it is likely your C-4 is not "bricked"; more likely there's a hardware failure event that cannot be recovered from.

1 Like

How to confirm that ?

It's a C4 hub... cant say you didnt get your moneys worth!!! My C4 only does webcore stuff and nothing else.

The C4 was always too slow to handle much, its been cr4eat runnning a single app to control the bathroom lights with a warning dim and acting as a relay for ZWave and Zigbeee for Homeassistant.

It's dissapointing that I cant even try unbrick the C4 (if that's the issue).

Reading the Protect subscription page, I get the impression I can still subscribe to Protect annual, is there any clause I missed that would prevent that given my C4 is unresponsive?

Probably not. You already reported it dead here so the cat is out of the box.

I believe that for the subscription to be activated, your hub has to connect to Hubitatโ€™s cloud.

From the symptoms youโ€™ve described, I think the eMMC is dead. If this was just an issue with the hub platform not running, the underlying Linux OS would still load and be responding to pings.

So I think this is not a recoverable situation.

1 Like

If you haven't tried rebooting your router, give it a shot. Best to pull power to the router for a minute and reconnect. I have a C4, C5 and C7 on my router. Very common for the C4 to fall off for whatever reason.