Hubitat C-7 Hub not working out of the box

Just got a C-7 hub today. Out of the box, I connected to LAN and power. I initially got a blue light. At no point did I get a green light. After 15 minutes waiting, I tried to find device. I cannot find device by any means on the network, even through my router. I disconnected and reconnected, now I have no lights at all. Any ideas, or is it, as I suspect DOA?

I have already replaced the micro USB cable and power supply (tried three with plenty of power).

Sounds like it’s time to pull in HE support... @bobbyD

I always go for the basics first - did you try a different LAN cable? Different switch port?

Yes, sent email to HE support. Different LAN cable and switch port. Same result, no lights from the device.

I seem to remember when I received my C7 I wasn't planning on converting from my C4 for a while so I plugged it to just have it powered (kind of like a burn-in) it stayed blue the whole time.

Did you try the "hubitat portal" or something like that, in you browser to find the unit. I don't recall the exact address but its in the instructions.

Yes, I went to the portal page and tried to find the device automatically and with MAC. These attempts were unsuccessfull. When I check my router, the hub does not appear at all.

That's not a good sign!

Did you get an email back with a ticket number?

Yes I got a ticket number in a response saying they will respond tomorrow. Figured I would search the support forums for help and ideas while I wait.

Yup. I just wanted to make sure Bobby D would have a ticket.

If you plug in the micro-USB cable and gently "lift" the back of the micro-USB plug upwards and hold it there, does the LED come on?

If the hub powers up doing that then it sounds like the micro-USB socket has come off the PCB inside.

C7's unfortunately seem to have a bit of a weak spot on the PCB where the micro-USB socket is soldered, if you're a bit rough with it (plugging and unplugging) then it doesn't take much to break the connections.

I'm sure HE support will sort you out in any case.

Thanks for the tip. I tried that but nothing. I agree that it is probably a power issue unless the device bricked itself doing a firmware update automatically when I first connected. Regardless, I am getting the device replaced through Amazon. Never heard back from HE support and I need the device working ASAP.

Thanks for your guidance.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.