Hubitat App with the Fire 7 Tablet Not Working

I would like to ask for help on getting the Hubitat Elevation Mobile app working on the Fire 7 Tablet (2022). My HE installation is running fine on my PCs and my Android phone. I did a web search and a Hubitat Community forum search but found no solutions.

I installed the Google Play Store APK ("manually") for the Fire 7 (12th Gen) on Fire OS 8:
Google Account Manager (latest version)] v7.1.2-25
Google Services Framework v10-6494331-29
GPS V23.05.14 (15400) February 17, 2023
Google Play Store (universal, nodpi)] V34.5.10-21 (83451010)

The play store came up fine.

I downloaded and installed the Hubitat Elevation app.

When HE App fired up the first time it asked the "Create Device" question (good) and then went to the "tutorial." At this point it went into an endless loop refreshing the screen.

I restarted the tablet and HE app again entered the endless loop refreshing the screen, to which I press the "Skip" option multiple times (don't know if that did anything though). Then I got this error message (not verbatim): says it β€œWon’t operate without Google Play Services."

From the above installation ... GPS is installed. I updated GPS to the latest version, but still get the error.


  1. Does the Habitat Mobile app work on the Fire 7 Tablet (2022)
  2. If the app does work, can I please get suggestions on what I can try to get my installation operational

Works fine for me. That said, delete the app, restart the tablet, then re install. cancel making another device then skip tutorial.

Rick, Thanks for the suggestion. Unfortunately, after multiple tries (different sequences) Hubitat is still stuck in an endless-loop at startup for me. Are you running the Fire 7 (2022, 12th Gen) tablet or one of the older generations?

Any other suggestions as to how I can proceed?

7 12th gen. If you are looking mainly for dashboard, use Hubivue available at

Rick et al, I was actually more looking for getting notifications. So getting the app to work seems important to me. Can you suggest any options as to how I would continue to debug/resolve my Fire 7 Hubitat endless loop issue?

I already have ActionTiles (an ecosystem that I haven't gotten into yet ... I am still working thru Konnected, Hubitat, Rule Manager, Android, Fire 7 and house wiring eco systems etc., at the moment).

After a review of Hubivue, would I be correct in assuming Hubivue is another ActionTiles?

No, unlike at , hubivue is 100% local. That said if all you're worried about is notifications, get Pushover. Far superior.

The Hubitat app works perfectly fine on Fire Tablet AFTER you install Google Play Services first.

Andy, Thanks for the response. I now understand that the Hubitat app works on the Fire 7 Tablet 2022. So I get it ... this is my issue. I just don't know how to resolve it. :slightly_frowning_face:

So (other than thinking on how to proceed using rlithgow1's alternate suggestions) ... I am really looking to get the second part of my question answered ... can I please get suggestions on what I can try to get my installation operational.

I think that I was clear on my installation process in my first post ... including the downloading and installation of Google Play Services (GPS) prior to using the Google Play Store to download and install the Hubitat Elevation app using the Google play store. I was thinking that as the Google Play Store was working I had Google Play Services loaded.

And Hubitat fires up too ... but goes into a loop ... so it's running ... sorta ...

Are you suggesting that I don't have Google Play Services installed based on my stated installation process?

I skimmed and missed the important details.

I also have a Fire 7 Tablet, but mine rooted and running AOSP Android. That is probably where the issue is. If you install Google Play Services on the stock Fire Tablet, it installs it as a User App and not a System App, which makes several other things not work properly too. I ran into this issue when I was trying to get Google's Family Link app working on my daughters Fire 7. There was a guide I found that gave instructions on how to get GPS working properly on Fire HD, but I opted to just get rid of the Amazon software entirely and go with AOSP Android.

Ah ... Thanks ... I did suspect we were going in that direction. I am new (this week actually) to the Fire 7 and couldn't jump to the "rooting" conclusion directly.

I've been in touch with Amazon a couple of times with respect to Fire 7 account "limitations." The worst "limitation" so far is that apps need to be installed for each account individually ... so the Fire 7 operates more like a phone than a "PC."

OK ... so now that's cleared up ... I had already proceeded to run the Hubitat LAN dashboard for the Fire 7 users as an interim solution ... as I decide how I want to proceed for the future.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.