Hubitat App - cloud access issues - Xiaomi Mi9T Pro Android 10

I was posting back on March 2nd regarding issues with cloud access to my Hubitat. At that time I thought that logging out of the app, uninstalling it, and reinstalling solved all the issues. However, due to the current lockdown, and having never once had an access issue from home wifi. I never had cause to follow this cloud issue through, and I totally forgot about it.

However, having just left the house for the first time in nearly three months I realised that when away from home, the security system and camera system that gets triggered by the non-presence of persons in the home did not switch on. Very quickly I discovered that the reason for this was that there was no cloud access to the Habitat. - "No response from hub".

As the Rule Machine routine involved requires the non-presence of two phones, one of them being mine, I decided to check the other phone to see if that could access the Hubitat through the cloud while I was unable. It turned out that the other phone was able and has been so every time that I have checked since.

This issue seems to have started when the OS was updated to Android 10. There is now quite an extensive level of permissions that can be allowed or refused for each app. I did allow all the permissions that were asked for by the app.

I have since tried removing the app and reinstalling it again. I thought that all was well for a couple of days, but I'm back again to 'No response from hub'. There has never once been an issue when connecting from home wifi.

Any suggestions as to how to proceed with trying to solve this would be very welcome.


The phone is a Xiaomi Mi9T Pro
Hubitat Elevation® Platform Version:
Hardware Version: Rev C-4
Fixed IP Address:

Do you have any Hubitat Dashboards created, that allow for cloud access? The reason I ask this as I'd like to see if the Hubitat Mobile App on your particular phone is the issue, or if it is something else. If you have a dashboard that supports cloud access, you can go into the Hub's list of active Apps, find Hubitat Dashboard app, and within it you'll find the link for the cloud dashboard (versus the local link.) Copy this link and try it on your phone. You can even save this link to your phone's desktop to use it like an app.

If this works while on WiFi, try it again with WiFi turned off on your phone, which will force your phone to use it's cellular data connection instead (as if you were away from home.) Let us know your results.

Thanks for your help ogieone.

I have two Dashboards created, one for PC use and one set out for phone use. I do not get access to these when I am unable to connect with the hub through the cloud.

I created a new Dashboard but I could not see any option to create a special dashboard that supports cloud access. Right-Click on the PC did give me an option to send the dashboard to the phone through a Chrome link, but on checking the link on the phone it was just the local IP address that worked perfectly with WiFi access but could not be reached with the WiFi off. I assume that is the info that you were looking for.

I have attached a Screenshot of the Debug info that I looked at when I was unable to get access while away earlier.

Here is the cloud link I was referring to. It is available from within the Hubs’s APPS page, under the Hubitat Dashboard app, then select one of your existing dashboards, and you’ll see something like the following.

This is the link to your dashboard via the Hubitat Cloud Server. If this link works both on WiFi, and when WiFi is turned off on your phone, then your hub is properly communicating via the Hubitat Cloud server.

When you create a link to access your dashboard via the web you should get a link that starts out like this (no IP address): ..... local=false

with a big long string where the .... is.

See the Dashboard app documentation for how to create the cloud link:

Loading Your Dashboard(s)

  1. In your Dashboard App, you will now see a link to the “Dashboards Menu”. Click on this and a new window/tab will open in your browser. Bookmark this URL / Link for quick access all your dashboards. Each dashboard has a Cloud and Local LAN Link. The Cloud Link allows your dashboard to be viewed from anywhere with internet access. The Local LAN link allows your dashboard to only be accessed on your home network. The Local LAN Dashboard will be faster to load and update. When you are on your local / home network, use this link.

Have you ever registered your hub? Registering the hub is required to get cloud access.

@SmartHomePrimer see this paragraph below from the OP. This is what led me to believe the hub is registered, since a second phone works properly. :wink:

Oh man, I totally missed that. So this is an Android OS issue it seems? :thinking:

Maybe... or possibly a Hubitat Portal account problem? If the Cloud Dashboard link works on his phone with no WiFi, we’ll know the hub is registered correctly. Then, the troubleshooting moves to the Android App and the Portal Account being used to login.

1 Like

Oh that’s a thought. @Davidod you could try changing the second account to admin in the portal, then delete what was previously the primary admin account, recreate it, and elevate it to admin.

Thanks for the clarification. Apologies to all, I missed the 'Sub Link' on the Dashboard.

BTW, I would just like to add that I had approximately six trouble-free months of operation before this issue started. As far as I can remember, Android 10 dropped to the phone in February, I think this issue might have 'coincidentally' started around the same time. Being retired, there isn't the daily commute away from the house, so the issue would not have been immediately obvious. There is also the fact that perhaps two or three times out of ten it works perfectly.

I didn't create a second account. I merely used the original login details on the second phone. Could this cause issues?

I have now done that and the Cloud Dashboard on the phone has connected - without WiFi, but, obviously, I don't get as far as being able to select the Dashboard when I get "No response from hub'. This is 70/80% of the time. I tried turning off the second phone to ensure that it wasn't part of the equation, but that made no difference.

Sorry that is proving to be troublesome.

yes potentially, i had a similar issue before i created two accounts.

1 Like

OK, that sounds like a successful test to prove that your phone is capable of communicating with the Hubitat Cloud Endpoint Server without any issues. This means, IMHO, that your hub is working fine with the Hubitat cloud server (i.e. is is properly registered.)

Understood. So, this would appear to point to an issue with the Hubitat mobile app on your particular phone. Are you running the latest version of the Hubitat Mobile App? There is an Open Beta for the Hubitat Mobile App which you may want to try, as they update the beta much more frequently than the production releases in the Apple App Store and Google Play Store.

That is the actual app that I have been running, and the link says "You are a Tester" - see attached screen-print.

1 Like

In addition to earlier info, I meant to point out that I was running Avast mobile security; the icon can be seen on the Notification Bar on the Screen-prints, but I removed it totally and rechecked access without WiFi but the issue was unchanged so I reinstalled it again.

Sorry I missed your response and only just picked it up.
I have now set up the second account on the Hubitat, but unfortunately my problem still remains. The only thing that has changed is that the two accounts only get cloud the very occasional cloud access now.