Hubitat app cannot see any hubs, but the network can

So started with one hub, worked okay, got another two, nightmare, and going in the bin soon. So, first problem was DHCP, and read here change to static, so did that (192.168.1.10) the app took about 2 days to stop reporting the old IP address. put the extra two hubs on the network, same problem, in fact the original hub started showing the old DHCP IP (192.168.1.38) in the app. Then stage two of this mess. the hubs keep going missing of the app and the Hubitat web version of the app.

But during this time, I can see the hubs in "registered hubs" but on different (old) IP addresses. I never been able to see other hubs when setting up mesh, and now they keep falling off the app until I restart t5hem multiple times. The irony is I can still get to the hub's no problem by connecting direct to the IP within a browser.

My network is a flat switched network with multiple WAP's

The IP is cached and as you noticed, it may take a while for the new IP to be displayed. Can you reach all your hubs?

Before you give up, be sure to create a warranty case by visiting below page. Although it sounds like the problem may be related to your local network configuration, we would like to rule out that none of your hubs are dealing with a hardware malfunction.

I believe the hub's are all okay, as I can talk to them no problem by tapping in the IP address. and yes, that cache is a pain, but I think working its way out now, But when I go in to the find hub on the app, slowly the hubs fall off the app, I think this is the same reason why I cannot see them in the mesh option as well.

Yesterday I restarted the hubs multiple time until they appeared in the app "Find Hub" this morning only one is there, but they are still in "registered hubs" and I can connect to the hub from there. I can also connect is I use the mac address,

Could it be DNS, I use my local router as the DNS and then it forwards to the outside world. It may be the "Find Hub" is looking at DNS in some instances

The two issues are likely not related. The app uses the same cached IPs. One thing that might work is to log out, or remove and reinstall the app.

As for Hub Mesh, you may try changing the protocol that it's using. By default, Hub Mesh uses the UDP protocol for keeping devices in sync between your hubs, but UDP may not function properly with some mesh WiFi routers. If sync issues occur. you have the option to instead use the TCP protocol.

https://docs2.hubitat.com/en/user-interface/settings/hub-mesh

Change your DNS on the hub itself to 1.1.1.1 and see if things start working

So yesterday I updated all to the latest version of the software, couldn't do this before, they would all hang, and changed it to the 1.1.1.1 DNS, all looked good, could see all hubs on their correct IP address in the app, but got up this morning, checked, all vanished from the app, can find them no problem from a browser.
I have been messing about with these for about 2 weeks now, I think it's time to give up.

Are both hubs updating from the internet? Honestly it's better to have the hubs on DHCP then use reservations in your router for them.

1 Like

The recommendation is to use an address reservation in your router, not a static IP. Static IP seems to give some users problems, I would revert to DHCP and see if that fixes things.

1 Like

Download the Hubitat app