HubiGraph LongTerm Storage Error

Hi All,
Just manually installed all files for HubiGraph, created a Time Graph Tile OK. I only see 1 data point. Tried to run the Long Term Storage configurator as possible solution but it errors with the following:

Error 404

Child app not found for namespace: tchoward and name: Hubigraph Long Term Storage

The Page requested could not be found

If you are seeing this screen repeatedly, please contact Support. For assistance, email support@hubitat.com or go to community.hubitat.com.

My Hub has firmware 2.2.8.156
Cant find another post with this particular issue mentioned, anyone have any hints for me?

Without having used that option myself, I would expect it is trying to open an part of the app code and cannot find it. Are you sure you installed all the files? I'll see what I can find.

There is a file for the Long Term Storage child app, did you install that? Alternatively, were you not able to install this via HPM? I do remember reading some had issues over the last 8 months, but not sure if they were resolved, hopefully they were. If so, that would be your better option I would suggest. Here's a link to the app code if you need it:

https://raw.githubusercontent.com/tchoward/Hubitat/master/hubigraph_long_term_storage.groovy

Hi sburke781, thanks for the advice. You are right, I didn't have that file installed. I performed a manual install as the HPM has caused troubles for some people. I am still getting the same issue though, I get 1 data point on the Line Graph and if the value of the variable (watts) stays constant I don't get any other data points, unless there is a substantial change in that variable. At that stage I get a second data point reflecting the new value and a straight line joining the two, rather than a data point every 5 seconds. So if I force changes in the data value every 5 seconds I get a new data point every 5 seconds, but if it stays constant I would get 1 data point per year or more. I am worried that there may be more files I haven't installed yet that is causing this issue. Will have to try the HPM and see the result from that.Once again, thanks for your suggestion.

1 Like

That may not be an issue in Hubigraphs, depending on what you mean by:

My understanding of the way recording of attributes (State Variables) in devices works is that if there is no change to a value no event is "normally" stored. I also expect Hubigraphs is reading these events, more recently needing to then store them in a file on the hub. If you are forcing an event to be stored in some way and seeing it appear on a graph, I suspect Hubigraphs is behaving as intended, and the reason you are seeing no change is the way the power is being recorded for the device, or, more likely, the fact that the power reading is not changing.

What device are you trying to plot on the graph, and what driver / app are you using?

1 Like

Hi sburke781,
Thanks for the reply. Yes, I understand what you are saying. I need to clarify, my variable is the wattage from an outlet switch which is powering a heater. Its either high heat, low heat or just cool fan. If I am sampling per second with a Time Graph of 1 minute wide at say 960watts I then get 960 at second 1. I get nothing more displayed on the graph until the value changes significantly. Then at second 50 I switch to cool fan and get 15watts at the 50 second mark, say. Then the graph draws a straight line from 960 at second 1 to 15 at second 50, with no data points in between. But the data points at second 2 to second 49 should have been 960, but they don't appear. It looks to me that the data ONLY gets plotted on the graph if it has changed in value, other wise it is ignored. When I enabled the "bad data to display as zero" function then after second 1 all the values are 0 from second 2 to second 50. So it appears the Graph system treats any data that is not rapidly or significantly changing as bad data. I even manually REFRESHED the Device data many times to fool the graph into taking notice but no joy. I will fully remove HubiGraphs and try the package installer as previously mentioned, see what happens.
Regards...
goodvibes3

Extra points for persisting and being so methodical in trying to identify where the issue may lie.

Two points I would make:

My memory from having read about the development of the app is that Google charts were used, which I assume have a certain set of configuration settings, but I would not expect the same level as other tools. Essentially I am expecting Hubigraphs may be constrained by whatever Google make available as options to tweak the chart display.

I'd also check the preferences on the power meter device for anything where you can set what change in power qualifies as a change. I would still expect enough of a fluctuation in power to record regular readings. Could be wrong... But worth checking.

All that said, I'm sure others have used Hubigraphs to display power usage, so would be interested to hear others experiences.

Simon

Just thought I'd post here an error that is occurring on all 3 of my hubs.
Here is the error.

Summary

It appears on a variety of different devices not just temperature as in this case.
The error is always the same. Only the device is unique.
I have tried the following.
Rebooting hub. Error remains.
Delete all devices from LTS and delete the LTS child app.
Delete all hubigraph files referenced in File Manager.
Reboot hub.
Redefine the devices in LTS.
New files are then created in File Manager.
Error re-appears.
I have absolutely no idea what to try next and I'm wondering if something in the latest build has 'provoked' this isuue.

Is anyone else seeing problems?
Any thoughts on what else to try?

Like I say it is happening on all 3 of my hubs.

What are you trying to do with Hubigraphs, I assume from the log it is to chart the results for a temperature sensor? Do you know how the data in long-term storage file(s) is formatted, again I am assuming this is JSON, based on the error? Do you have a sample of the data in the LTS file, in particular the first character or line from the file? Don't need to post this text here if you don't want, you can PM me if you prefer.

Hi Simon.
Thanks for the response.
Your correct, I'm logging the temperature of my Aquarium in a graph across 7 days.
It's now only graphing the temperature events that are listed against the device as no changes are being written to the LTS file because of the error. This is now happening on all 3 hubs graphing temperature, humidity, cp load, memory. Everything basically. Looking at the LTS file in file manager there are only a few events listed. I'll post when I'm on my PC.
I'm starting to lean toward something that has changed with the latest firmware update.
I would have thought other people would be reporting it though.
I may try deleting Hubigraphs on my 'play' C3 and starting again to see if it clears things.
BTW my hubs are C3, 5 and 7 so it's across them all.

EDIT. Just completed a complete uninstall of all apps and drivers for hubigraphs. Deleted all files from file manager.
Re-installed hubigraphs, defined a couple of devices into LTS and I'm still getting the same error. My only conclusion it must be a change in 2.2.9.137. Cannot think what else it could be. I suppose that is the problem with custom apps. :frowning_face:

Here is the LTS file in file manager BTW.

Summary

Your image upload doesn't seem to have worked, but I am expecting it may not be the issue now, based on one of your comments I need to find again... am wondering if it is an issue in trying to write to the LTS file, more so than trying to read from it.

I'm thinking the same.
Amended the image above to work now. :blush:

The problem I don't think Hubigraphs is supported anymore.

Yeah, the dev moving on doesn't help, but code doesn't just stop working on it's own.... And the data from your LTS file looks ok.... And the fact no-one else is reporting the error is odd...

We could continue to work through why you are having issues, or you could spend the time looking at other options for reporting these temperature readings.... In the meantime maybe I'll have an epiphany overnight... or someone else...

I'm wondering whether the spaces in the sensor name may pose an issue for you... Are you likely to have updated the Hubigraphs drivers lately (via HPM or some other method)?

Nothing has changed from a driver or device point of view.
The road I'm going down now is define a virtual temp device and increase the event limit for the device to record the values. This should get round the issue by not using LTS. It will increase DB size but I'll see how it goes.

1 Like

Hi @bravenel @gopher.ny
This is a general question I suppose.
Since the latest upgrade to 2.2.9.xxx I am seeing issues with Hubigraphs.
I appreciate that this is a community app that is no longer supported by the original developer so you may see this as a 'contact the publisher' scenario.
In Hubigraphs we are able to store events in a Long Term Storage (LTS) file in file manager (FM). This is then read by Hubigraphs to give a nice graph that can cover definable days.
What I am seeing is hubigraphs is now unable to write to the LTS file in FM. It is throwing the following error.

Summary

So my question is has something changed in the FM area which is causing this error?
If so, and I know this is cheeky, :blush: but any thoughts on what could be in the code the FM no longer likes.
I must admit I've not seen anyone else reporting this issue so it may just be me but I have tried deleting the app and all of it's drivers etc. and reinstalling but the issue remains.
Thanks in advance.

This is a JSON parse exception... take a look at the string the app is trying to parse, it's not up to JSON specs, so it's complaining.

Thanks for the prompt response.
Is this because of a change to FM?
Just wondering why it has started.
Thanks.

There were no changes to file management. There can always be a bug, but no direct changes were made to related code.

OK. Thanks. I'll see if I can play with the code and get lucky. :wink:

Download the Hubitat app