Hubconnect became disconnected

I just found out that my instance of HubConnect, connected to a Smartthings Hub, has somehow become inoperable. the scary thing about this is the message I get in Smartthings, that "...something went wrong" and "Please reinstall the app." Does that truly mean I need to start over?

Funny thing is, In HubConnect on Hubitat it shows everything is connected. Originally it said Offline, I generated the connection key again and put it in the ST app. From then on HubConnect on Hubitat says Connected, but ST says OFFLINE.

Is it truly disconnected? Or is this part of their "change". Have you tried operating a device still on it?

1 Like

HubConnect has a Device, representing the "other hub". So on SmartThings, there's a device, probably with the name "Server Hub" (but you are allowed to name it anything, but default is Server Hub") and you should verify that it is "on".

I just looked at mine using both Classic app and New app and I can see it's On either way.

It shows both On and Present for me.

A similar Device exists on my Server hub for each of the connected hubs. I've found the fast way to find them is to simply click the Type column and then scroll to HubConnect Remote Hub device type.
I've seen/heard of the device showing as Off.. and that would cause a problem.

Screen Shot 2020-10-09 at 10.29.09 AM Screen Shot 2020-10-09 at 10.28.46 AM

Maybe I have made a mess of things, but before I saw this note, after I was unable to remove the Hubconnect instance from SmartThings, I took the server components off my Hubitat hub. So except for some HubConnect drivers in the driver list the server components aren't there. I looked in my device list in the new app and I can find nothing called "Server Hub. In the SmartApps screen there is an entry called Jeppsen Hubitat (that's my server hub) and it says [OFFLINE] by it. I tried going into the IDE to remove it. There is one entry called, " [shackrat : HubConnect Remote Client]. I opened that app and tried to delete it. I got the message "This SmartApp can't be deleted at this time because it is installed by one or more users".

Does this make sense to you? I hope I haven't done something irreversible.

I found my problem and successfully removed, then reinstalled HubConnect. For about two days it worked fine. Today there are no updates coming from any ST device, and I cannot add new devices from ST even though I have made sure the correct drivers are in place. I shutdown/restarted the C7 hub and did the same for the ST hub. Still not communicating, although devices work fine in the ST hub but I cannot see their status or control them from Hubitat. The HubConnect Remote Client in ST shows [ONLINE]. Any suggestions?

I have been looking in both my C7 hub and SmartThings hub and I don't see the devices you mention in your previous post. Perhaps I installed it incorrectly. I have looked in both the app and the ST IDE, as well as the device list on the C7. But if I installed it incorrectly why would it work for a couple of days?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.