Hub Wierdness - Drivers not deleting, past logs taking 1 minute to load

Not sure if this is because I've have about 60 devices now or because I installed some user drivers from GitHub or perhaps browser related..., but:

  • clicking on logs, past events, takes about 1 minute for browser to complete action....during which browser complains that a script is taking forever to run...
  • attempting to delete drivers which might be slowing down the hub just reloads the driver code page with the driver still present
  • getting persistant 'hub unreachable' in the notifications popup, doesn't even go away after rebooting

What firmware version are you on? There have been many reported issues with recent fimare versions that the latest one should fix.

Hubitat Elevation® Platform Version

Hardware Version

Rev C-5

You should probably reach out to support asap.

Just noticed that it isn't letting me delete dashboards either... rebooting doesn't help.... really wierd.

Some random suggestion to consider:

  1. make a manual backup under settings on the hub and save to your local PC to be safe.
  2. select ‘shut down’ on your hub under settings.
  3. unplug the power after the shut down is complete and wait for 1 minute. Then plug the power back in
  4. after it boots back up fully, attempt again to delete the drivers.

You probably already tried the above, but just in case...

I'm testing now with the following platforms/browsers:
Windows - Edge
Windows - Firefox
Android - Bing App
Android - Samsung Internet App (Chromium?)

Strangely enough, 'only' Android- Samsung Internet App managed to load the past logs quickly or delete apps/drivers. However, device discovery still fails with it and the notifications icon still says 'hub unreachable' when using it.

A lot of functionality seems to be broken under Microsoft Edge, Firefox, and Bing - even though all those platforms worked fine a few months ago before the latest firmware changes. I'm not sure why loading of past logs is just so slow when using anything but chromium based browsers.

I'm starting to wonder whether if chrome is the only supported browser now and larger zwave networks just are especially buggy with current hubitat.

Every browser does generate the 'hub unreachable' notification and there is no clue what that means as the hub is obviously still on the network and even reachable via the mobile app.

I've rebooted and upgraded firmware for weeks, shutdown, toggled zwave on/off, doesn't help.

What does a continuous ping from your computer say? Does it drop pings?

0% packet loss, average 2ms pings, based on 2 minutes of mtr running pings (windows desktop), no idea what the packet loss is on the android device which is on 802.11n 2.4ghz wifi

Ok, I would take a backup, do a softReset and restore the backup. Something is clearly going on there. A softReset will rebuild the database

That is what I would try, too.

You might like to DISABLE the custom drivers and/ or Apps, one by one, testing responsiveness as you work your way through them. It’s not going to be quick though.
Perhaps a Hub update tidied up some wonky code that was irrelevant before and now it’s causing issues.
As @stephack mentioned, you should reach out to support