Hub variables w/o connectors in dashboard

@bravenel

Hub variables are not showing in the dashboard when asked from the link in the HE home page only if you access the dashboard from the main app.

I am trying to add a hub variable without connector and unable to. I added to choose variable list in app/dashboard. Whenever, I try to add tile for variable type it says no authorized variables. Is this how you added yours? Does it still work in 2.3.0 for you? Thanks

I have no problem adding the hub variables to the dashboard. be sure to remove the connector from the dashboard first and then you will see an additional drop-down for variables. Inside the dashboard editor, you have to choose the "variable" from the new drop-down menu that defaults to "device" on each tile.

I removed the tile with the hub variable with connector from dashboard.
I removed the connector from hub variable in hub variables
I added the variable in choose variables in the app/dashboard screen where you add devices (below it)
I find my variable in list of unsorted variables
I go to actual dashboard and add tile (+)
In add tile I select type as variable .. (hub variable no longer in device list)
Under variable type it says no authorized hub variables

I was under the assumption I could delete an existing connector and still use variable.
There is no way I will replace my variables with newly created ones.

I hope I am doing something wrong.....

Thanks for response.

You don't need a connector to use the variable in dashboard. Not sure what is causing the "no authorized variables error.

So you have your variables selected in the choose variables list for your dashboard?
Is your list unsorted too?

Yes they are unsorted, kind of weird, but I'm sure it was just an oversight.

I appreciate your help.

Me and Hubitat may part ways.

Was this with the cloud link? Can you try again to check if it was resolved?

Unsorted variables still pending.

local

same error



So here's the interesting part if I go from the menu to the dashboard:

but if I use the local link from the dashboard child app:

So while the dashboard link looks like it is purely local, it is semi-acting like a cloud link (semi because background image is coming from the hub local file system.

Edit: this hub is registered for beta releases so if you need a test subject...

I am using a local link when I get the error. Maybe it works differently if there were variables authorized before upgrade as I am unable to get the first one in.

or the released version is broke and a previous beta version worked and allowed the variables to be added.

I just added those variables in before posting as I wasn't getting the dashboard to work with them prior. Hub [C7] is on the current production release (2.3.0.111).

maybe there are too many variables between hub setups lol.

anyway I tried from dashboard menu, local and cloud links and cellphone.

thanks for helping

What I'm seeing is that the Legacy Dashboard Links don't allow the variables to be added in the dashboards when used, but the Dashboard Direct Links work.

let me try

you are brilliant!!!!!!!!!!!!!!!!!!!!!!!! yes I agree and can get it to work from that link

1 Like

Shhhhhh, I'm trying to keep that a secret.
:rofl:

so is it working as designed or a problem? I do not want to change all my links throughout my dashboards.

Download the Hubitat app