Hub Variable U/I Behavior

Check out the hub variable 4th from the bottom. I'm not experiencing any problems with its usage, but the UI looks odd, like maybe it shouldn't appear this way. Also, I can't click on the hub variable to see where it's being used like I can all the others.

Figure Hubitat staff wants to know about this.... @bobbyD

It has a corrupted name. You should Delete it, and create it new. You'll have to track down which apps where it is in use manually, although presumably that should be pretty obvious.

Thanks I've got it solved, but thought you'd appreciate knowing the unexpected behavior along the way. I create a new, presumably pristine variable (called Override_MB below). I was planning to swap out the old corrupted variable for this new one in 3-4 apps, and then delete the bad boy.

Except, look what happened. All I had done so far was swap variables in one app:

The only wild a$$ guess I can offer is that the first app I tried was on pause. Not sure if that's related.

So I deleted the paused app, deleted the new variable, and everything still works.

Thanks, this is a bug. Found and the fix will be in the next release.

2 Likes

Download the Hubitat app