Hub Variable Creation Bug?

I think I may have found a bug in the Hub Variable creation process.

When I attempt to create my 63rd DateTime Hub variable, the system throws an error.

HubVariableError1

If I then click on Settings -> Hub Variables, sometimes it throws the same error for a few seconds. It will then eventually show me the list of variables, and the DateTime variable I tried to create shows up in the list, but only with a time:

HubVariableError2

I have deleted this variable and added a new one many times, trying to change the name, change the time, change the date etc., but the same thing happens.

I also restored the whole database once, which deleted ~13 DateTime variables I had recently added. Then it lets me add back a lot of the DateTime variables until I try to add the 63rd one, and the same error cycle happens. If I ignore this error and keep the erroneous variable in the list and try to add another DateTime variable, the same error happens on that additional DateTime varibale.

For reference I have 136 total variables before trying to add this 63rd DateTime variable. If I try to add another variable type, for example a Number, that is allowed without error, even if I leave the erroneous DateTime variable in the list.

So it doesn't seem to be a problem with the total variable count exceeding some limit, but perhaps is an issue with the quantity of DateTime variables I am trying to create.

Tagging @bravenel

Does anyone know if there have been any bug fixes related to @Automatican's discovery above? I'm on 2.3.2.128 and think I may have run into the same issue trying to create more hub variables. For me my variables break down into counts of the following types: 26 x datetime, 14 x string, 72 x number, 13 x decimal, and 4 x Boolean. I get the "Unexpected Error - An unexpected error has occurred trying to load the app. Check Logs for more information." message when I try to create a new variable. There are no extra details in the logs. If I delete one variable, I can usually create a new one afterwards but only if I keep the name short. Am I running out of memory?

Update: I was able to create a new datetime variable after renaming a bunch of other variables with shorter names. However, when I clicked done on the new datetime variable, I still got the Unexpected Error but the variable was created anyway.

Can you PM me your hub id? I'll take a look in the engineering logs on the hub.

As far as I'm aware, this hasn't been addressed.

Looks like you're running into a limit on the number of form parameters submitted at once.
I'll bump it up (double it) for the next release/iteration.

Hi @Automatican. It appears staff member @gopher.ny debugged my issue and made a fix. Look for 2.3.2.131 or later. Seems like it could likely fix your variable create issue too.

-Dave

Download the Hubitat app