Hub Update: Download Speeds

I have 2 C7 hubs. Hub1 is connected directly to an AP router which is connected to my main router. Hub2 is connected directly to my main router.
When updating my hubs, download speed for hub1 is about 5 seconds. Hub 2 the download can take 3+ minutes This doesnt make sense. Why such huge difference in speed for 2 hubs both on the same network.

I have noticed this as well.. I have 2 hubs a C5 and a C7. The C5 is downloads without an issue but the C7 is very slow to download. Sadly though I haven't had any time to rule out any potential wire issue or switch issue so I haven't posted anything. But I saw your post and thought I'd mention I have seen a similar thing. I don't think it is a HE hub issue. I think it's a network/wire issue. Once I troubleshoot mine (when I find the time that is LOL) I will see if I can find the culprit on my network and I'll share my finding.

Not sure if this latest release did or not but a lot of the releases have had 2 different releases one for the C-5 and previous and one for the C-7 specifically alot pertaining to the new 700 series chip and stack.

So the 2 different hubs are downloading 2 different files with different file sizes would be the most logical explanation.

1 Like

I thought the same thing but the file size HE "says" it's downloading are the same size.. But again, I haven't gotten any chance to test anything as life has gotten in the way (as it always does LOL).. I'm hoping to find time this weekend to poke around at it..

It's the same exact firmware/file for all hub versions.
Depending on the router, speed negotiation between router and hub may cause this. We've seen it with Netgear routers in particular, but there's a very wide variety of routers running different software versions, so there's no way to tell what works best. Here are the endpoints to experiment with if downloads are slow:

/hub/advanced/network/lanautonegconfigenable - sets Ethernet speed to fixed 100mbps
/hub/advanced/network/lanautonegconfigdisable - allows Ethernet to negotiate speed
/hub/advanced/network/lanautonegconfigstatus - shows current setting, with true = fixed 100mbps

If things work fine and downloads take seconds, don't go around messing with these. There's no upside to be found.

1 Like

It may be that they have multiple update servers which are load balanced. One hub may download from one source and the other from another which may have a higher utilisation at that moment. They may even use a content delivery network where the server you use depends on where in the world you are located. If you are in the US you may use a server that is located in the US where as someone in the UK may use a UK based server.

I have also seen this, as well as the update taking a longer time on my c-7. Figured it was because it had all my devices on it vs the c-5 that’s not running much. :confused:

We use AWS, which provides content distribution services among many other things.

1 Like

The things is, at the risk of repeating myself, Hub1, which has super fast downloads, is connected to an AP (Asus AC68U) router which connected to my main (Asus AC86U) router. Hub2, super slow downloads, is connected directly to the same main router. If anything is likely to be slow it should be the hub1 connected to an AP.

This difference in speeds is a regular occurrence. In other words, Hub 1 is always fast, Hub2 is always slow. I have tried different network cables (cat 6 or 6e) as well as different ports. No difference. Here is a snapshot of the ethernet connection to my main router. Lan2 = AP (with Hub1), Lan3 = Hub2 direct.

2021-05-11 (1)

In my case, its the reverse. Hub 1 has a much bigger load than Hub2

If you have an Access Point, it should have DCHP turned off. There should be only one router in your system unless you have different subnetworks established.

If your Access Point is connected to the main router using Ethernet cable, the download speeds should be similar for both hubs. However, if your Access Point is connected to your main router using WiFI, the download speed will be slower as there is a lot of traffic passed between the two devices that can slow things down a lot.

However, you indicated that you are getting a faster download speed on the Access Point than on the main router.

I can understand how the download speed might be different between the C5 and C7 hubs as they have different capabilities and thus the firmware may be different. However, with two C7 hubs, if they were running the same firmware to start and you are updating to the same firmware for each, I would either expect the download speed to be similar or the hub connected to the AP might take longer. But that is not what you reported.

Remember also that download speeds are often affected by what else is going on across the Internet. Are several people trying to download from Hubitat at the same time? Is your ISP throttling your download speeds due to high demand? There are multiple possibilities.

Exactly. The difference between the two is huge. 5 seconds vs 3+ minutes. Something isnt right

I see the same thing between my three hubs. It's been doing this since I got it, I reported it the end of last year, here.

I have two C5s and one C7. Both C5s always download quickly, the C7 is always much slower. Other than being slower I notice no other difference.

My C7 is connected to a wireless AP, as is one of my C5s, The other C5 is connected directly to my main router.


@gopher.ny These settings seem... backward.

autonegconfigenable should allow auto negotiation. disable would mean set to some fixed speed. Status showing true should mean auto negotiation is enabled, and false meaning it's set to forced...

Is there a reason these are flipped?

Both my hubs return: "auto negotiation config true" which from your description means they're forced to 100mbit rather than being set to auto negotiate?

Forcing ethernet speed should rarely be a thing anymore... heck, with gigabit ethernet it's specifically against the standard to force gig speed.

I'm putting them out as is... these endpoints were present as they are since mid-2019.
It's probably worth renaming them for clarity in future versions.


totally understood. just curious why they're backward. lol. =) Obviously renaming them could be complicated if anything is querying them.

Gonna flip both of mine to false I guess? I do recall back in my early C-5 days it was a recommended fix for something or other.

FYI, I just checked all three of my hubs and they were all set to True. As I had yet to download the the latest Hotfix, I decided to update the C7 to auto negotiate and see if it made a difference in the download rate and it did. My C7 was still slightly slower than my two C5s but only marginally so. The two C5s went from 0% to 100% in about 4 to 5 steps, the C7 took about 7 or 8, instead going up 1% every 2 to 3 seconds as it has been doing ever since I got it.

I get 404 error

Add hub before advanced. I thought the same thing when I first tried it. Hub replaced by IP, but Hub needs to be in there.

1 Like

Right, it's