Hub stuck initializing at 15% w/ blue light

I have a C7 running We have had many connectivity problems in the last 24 hours and this hub has taken several hits with not-so-perfect shutdowns etc. I have been trying to reboot it for a couple of hours, and I can't get it to initialize past 15%. I have tried the diagnostic tool, and it leads to the same screen. Tried pushing the reset button, same thing. Is there any other way I can bring this back to life?

Use the diagnostic tool: Hubitat Diagnostic Tool | Hubitat Documentation

Click Download backups > download all your backups to your PC

Do a soft reset, then restore from your newest downloaded backup. (Restoring a backup does not change the firmware version, you can restore any backup to any firmware, does not need to match).

If still hanging up, try your next newest backup, etc... try all the backups newest to oldest to see if one will work.

Often times going back one or two backups is what fixes it.

If none of that works, try using Restore Previous Version to roll back to a prior major firmware version, then try the above again.

For Reference:

@gopher.ny @bobbyD


And if none of @jtp10181 's suggestions fix it, maybe try using a different Power Supply?

Also, and recent network hardware/configuration changes lately?

1 Like

I can't access the diagnostic tool on that hub. It comes up with the same initializing 15% screen. It doesn't access the hub at all. Wouldnt In need to actually be able to access the hub to get a backup?
I just shut down the port and pulled the ethernet cord (POE Splitter), though I did this earlier and left it like that for about an hour, and that didn't help any.

Try without the PoE splitter. Use a dedicated power supply for a test.

The diagnostic tool can be accessed using port 8081 as explained in the docs. For every other person who has had this issues the diagnostic tool was reachable. Show a screenshot of your browser with the address bar showing.

1 Like

It's not working. this is the screen I get , notice the address is the 8081 port.

Your screenshot does not not show the address bar.

yeah I realized after i posted it it didnt have the address bar in it.

You need to use a colon ( : ) to add a port, not a /




Looks like I'm dead in the water and will have to rebuild all the rules by hand. The mac address is unreadable.

If it pings, then you can get the MAC address from your router.


Awesome, I hadn't thought of that!


Thanks @JTP and @ogiewon , this worked. First time (in about 5 years since I started using hubitat) that I came across this scenario.


Also, lesson learned, Im going to a label on the front of all the hubs with the MAC address so I don't have that issue again.


You can also visit >> Registered Hubs >> Hub Details.


I keep the MAC in my password saver so I don't have to go hunting it down if I need to get in there!


Yeah it appears to be some sort of new bug in 2.3.7, very low incident rate though.


If you know the IP, you can also just make an ARP request. So in your case Clay, you could just type ARP and it will return something like ( at 34:e1:d1:8x:xx:xx on en0 ifscope [ethernet], but with your specific hub MAC address of course.


You can also retrieve your mac address by logging into your hubitat account. Tap on registered hubs. Then, tap on hub details.