Hub Stuck at 30% Initializing After Update Last Night

Pressed update last night (to 2.2.7.123) on my way to bed and woke up to it not working. Rebooted and now it's stuck at 30%... Have tried rebooting 3 times now and it never gets passed 30%... Have tried rolling back to previous versions 2.2.7 (both versions, 122 & 121) and 2.2.6...

Found a similar issue from a year ago and going to try the soft reboot and restore they mentioned.

And it's failing to soft reboot saying error 401.....

Are you able to post a screenshot?

Did you do the Soft Reset from http://hubitat.local:8081 ? What happened before you got error 401?

I opened 8081, pressed the roll back options, but each one failed to get past 30%..

And soft reset opens like it should and when I press the go option I get the error.

I also tried safe mode which also gives me the 401 error.

Okay - we may need to pull-in the experts… @bobbyD, @gopher.ny any ideas?

I see the hub running 2.2.7.123 and responding to support tool requests, which means it's past the stuck point. Was the issue resolved?

1 Like

@gopher.ny no, it's not properly responding, I properly responded to the roll back request, but won't soft reset or anything else. It's still stuck at 30% I even left the hours for 5 hours hoping it might resolve itself. I can open 8081 an I have tried rolling back all the way to 2.2.6.134 but it still won't run. It's been running and updating fine all the way until I said to update last night to 2.2.7.123.

And no, logout/login do not do anything on any browser nor in private browsing mode...

[UPDATE]
I was able to finally login by moving the Hubitat to separate VLAN and it it says the soft reset has succeeded. Now it's on a "Get Started" page finally. going to try and restore my backup from before the updates.

Update2:
It is now sort of running again, I think. I'm trying to control the zigbee lights, but they are not responding at this time. Going to wait a few minutes and test again.

Be sure to download it and restore it from the download. That will fix DB corruption if there is any.

Try pairing the Zigbee lights again. The hub should recognize that they were already paired and slot them back in the existing devices.

@Sebastien I was able to get it to work by changing to new VLAN/IP on the hub, It allowed me to login and soft reset fully. The zigbee lights I sent commands to and while it was trying I manually turned them off & back on and they all work now. Only hiccup is one of my rules isn't running right, I think I'm going to have to delete it and redo it (but it's not very complex)

1 Like

Thanks for the update. Glad it all mostly works again!

You’ve mentioned this (2.2.8) a couple times. That platform version isn’t released. What version are you referring to?

1 Like

There's no 2.2.8 at this time, not even an internal build. Must be a typo.

1 Like

@aaiyar @gopher.ny it wasn't a typo, it was my guess as to the version since I couldn't at the time see the version or remember what I accepted (was just the newest that day). It was the newest 2.2.7 (123 I believe). I'll edit my posts.

2 Likes

Download the Hubitat app