Hub slows down over a day

I have a problem with my hub. It slows down over the course of a day or two. Its progressive, degenerative; commands and actions take longer and longer to respond. The general logs don't really provide a whole lot of detail. It is difficult to correlate to any thing I did/ changes I have made.

Is there more I can do beyond disabling rules 1 by 1 to troubleshoot this? I emailed support, a week or two ago but haven't heard back. I did search the forum a bit and most of the time people recommended getting ahold of support as they have more advanced logging capability. Any recommendations would be appreciated!



This problem has been around for many months now and discussed in numerous threads. The common practice is to disable any driver or app that is not supported by Hubitat. While this is understandable from a support position, many have followed this path only to not find any common cause. Whatever is causing this widespread problem it doesn't seem to be linked to anything that can be pointed to. Some people experience a slowdown in a days time. In my situation the slowness happens like clockwork at 3.5 days. Still others that can go a week or more. The problem is really all over the place making it difficult to tie down.

Are you using the latest firmware ? or helps the reboot less often but 3 days is what I'm getting since the latest update.

This tread and many, many others could help you identify the cause but so far nothing major except the latest update that improved the situation somewhat for some people including me.

Every single time I have experienced a slow down, I have been able to trace it down to a specific issue.. Usually a piece of misbehaving code or device... I only reboot my hub for hub firmware updates..
I realize that everyone’s use cases are different and some may have legitimate issues that aren’t specifically identifiable. Just sharing my experience.


Interesting, you can find every cause of a slowdown. I wish I had the knowledge to fix my issue or issues. I guess I will have to start from the beginning and disable my rules and third party apps, again.

I've read that some people experienced database corruption. How would I know if that was the case ? I have never contacted support, does Hubitat have a way to find database problems ?

The Hubitat guys do not really have any further means of finding database problems but they can tell you IF they suspect your Database is corrupt.
Restoring a backup from a few months ago should get you an NON-corrupt database but note that if you have had excessive polling or driver or app issues then those will be remaining.
There are a few "suspect"apps such as the beta Chromecast app that has caused issues for some users, has have unsupported devices which should be disabled and your Meshes left to settle for at least 24hrs.
Things that have tripped other users include:
Try not creating complex Rules (several simple rules are better than 1 complex rule)
Limit your use of Global Variables (recent hotfix)
Make sure the "use ALL devices" is not used on any dashboards. Just select the devices you require.

1 Like

When I have experienced a DB problem there has been errors in the logs that contain the letters 'SQL' somewhere in the error report. This refers to the DB.
(I believe).

I'll watch that next time

Thanks for the info. I'm trying to simplify my rules as of this moment. I didn't think that having more rules would be better than trying to do the most in a single rule.

This issue started for me as well, probably for a few weeks at least (Maybe months). I haven't changed anything on the hub side (Other than the changes necessary to "fix" the problems introduced in each update) with regards to apps/drivers. It started shortly after an update but I haven't kept notes so I don't remember on what version number it started exactly.

I have in general been having problems with almost every update and no longer have the sufficient free time to track down and solve every single problem I experience with this hub.

Hi Everyone,

Thanks for your responses. I have tried disabling un-supported drivers, large rules, etc. So far, as someone mentioned, I am having difficulty correlating it to any in particular.

Interestingly, I replaced one of my switches and noticed that the hardware ethernet link was dropping out intermittently! There were some suggesting that it was incompatibility in the auto-negotiate speed process, so I manually set the speed to 10 Mbps full. After doing so, the ethernet stopped dropping out. But, then i when i woke up this morning it was dropping out again, and worse than before, so bad that I couldn't connect at all. I thought the switch port or cable could be bad so I tried swapping both and the problem follows the Hubitat. Going to play around with this as well as reverting back to some really old images, if I can find one. If I still see the issue, i will revert to factory settings and see if the problem goes away.


Hi @dallasjwilm, did you ever figure out why your ethernet was dropping out?
I have the same issue, if I reboot my switch or even unplug the ethernet cable between the switch and HE, after I plug it back in, the HE never tries to reconnect.. no link light on switch. I've tried 3 different makes of switches, HE is the same on all of them. The only way I've been able to get it to recover is reboot the HE.

Have your tired a new power cord?

1 Like


And/or power supply.

@Scottdogster , a very well timed question as I was going to post an update in about 2 days.

I decided to start by removing my power monitoring outlets that I was using to monitor washer and dryer power usage to determine when they had completed. I had initially noticed that they report A LOT of frequent updates. After trying to slow down those updates in the device config, it got better but they were still quite frequent. I decided to force remove them as I couldn't get them to disassociate using the standard method. After seeing no change, I decided to remove them by physically removing them so that they could not transmit at all. I did actually see some improvement after this where the hub took a little longer before it froze/slowed down again. However, it would still slow down.

I ended up trying to restore a very old image which didn't work, if I recall it was because it was too old as my firmware had been updated a number of times since the image was created. So, I instead removed all apps except ecobee, groups and scenes, dashboard, hue bridge, lutron integrator, and rule machine. No improvement after doing this.

Next, after looking at my historical logs I saw a very occasional error related to a "column." I decided to perform a Soft Reset. This took care of the error issue but did not take care of the performance issue.

Finally, about a week and a half ago now, I created a firewall rule on my router to deny the Hubitat access to the internet. After doing so, the hubitat has not experienced any performance degredation! The problem with this has obvious drawbacks, the main one for me being that I can't control my Ecobee Thermostat now since it is cloud based control. I am going to give this a couple more days or so to be able to say it has been ~2 weeks since a slow down. After doing that, I will probably re-enable WAN/internet access and see if the problem returns. If it does, I will disable internet access again and see if the problem disappears.

Very frustrated. Lots of work destroyed trying to solve this problem. No response from Hubitat, ironically just a random survey asking if they've been supportive/helpful and that they want to be supportive/helpful. It would be nice to see a summary of all possible symptoms and solutions. I'm fairly angry. Wish I could recommend this hub to people as I really like the concept.

At some point, I may try a Hard Reset and see if that improves things when connected to the internet.

I will return and post results after I try re-enabling WAN access.

So my general experience is this.

When all apps are completely removed, my hub doesn’t need a reboot. :slight_smile:

When apps are installed things slow down over time.

I’ve spent countless hours trying to figure this out. I ended up just setting up a nightly reboot...


I have 6 hubs...

I have two hubs that are, individually, hugely similar to anyone else's, I believe.

I have an "upstairs hub" with 25 ZWave devices and 23 Zigbee devices. The total devices (from the Devices page) is 69, meaning there are 12 Pico's and a Lutron, with a few 'virtual devices'.

For Apps, it's got ABC (for the Pico's), and the Lutron Integrator, HubConnect (naturally :slight_smile: ), Rule Machine with 29 Rules (a mix of 2.5, 3.0 and 4.0 Rules). I also have my Get Attributes App which is not a 'running' app. It only runs when I click the Apps 'go' button. Lastly, I have ZWave Poller for ONE ZWave device.

I doubt that it's an exact match to anyone's hub but I bet it's similar in counts of devices and apps, similar in count and 'complexity' of Rules.

I reboot with every Platform update. It's not my Development hub (I have two, because of my delight in HubConnect) and so I haven't (yet) needed to reboot because of a code error I injected. I'm on the latest Platform I am certain that rebooting to every platform update is a factor in this hub's stability. But, on the other hand, we go more than a month sometimes between platform updates... then 4 in a week :smiley: Therefore I won't claim amazing stability when the max uptime between reboots is a month or so. BUT I do NOT have any form of hub rebooting plan running. For any sort of DAILY problem that a daily reboot fixes, I have nothing like that.

I really should be seeing issues over a one week period because I really have nothing special I've done. I have a mix of built-in and community apps. I have 'chatty' devices, specifically the Aeon MultiSensor 6 (7 on this specific hub) and Poller's running. I have no compunction against running live logging for more than a day. At least once a day I bring up a browser and open all and poke around.. I don't make changes very often any more, unless its to try and whip up a response to posts here.

Really, I should be having problems !! Can someone explain why I don't?? :smiley:


Because you're lucky. :slight_smile:

For the heck of it, I'm going to disable my hub reboot app and see how it performs. I will give it until Monday morning if it doesn't drive me to crazy! :slight_smile:

I'll report back next week. Ping me if I forget.

One thing to mention, do you have description logging on for all your devices?

As far as I know, yes. I've never knowingly turned it off.

Screen Shot 2020-06-12 at 1.34.57 PM