Hub slow all of a sudden

I posted back in Jan about my hub slowing down, however back then I pointed this to an app that was installed and all has been good since.
However this morning we have woke to find the hub pretty unresponsive. Automations are firing slower than usual but I am unable to use the UI (tried on multiple devices).
I can't get to the devices page and the settings page loads after a while but I can't do much... Trying to reboot the hub isn't really happening.

Any advice on how I can get this back to a usable state? Nothing has been added or changed to the hub and our internal wifi network etc have had no changes.

Reboot using http://hub_ip:8081
Check your logs for any errors or obvious spamming from devices.


Tried to access that but then found wasn't pingable so it had fully crashed this time...

Had to pull the power, but all is still slow after this. Will try and get to the logs

Yeah if that link doesn't work then it's totally screwed and you have to pull the plug. But this really isn't good for the hub. Always best to check that admin page first and try to reboot from there.

If it's still running slow after giving it a while to settle down I would do a soft reset. First take a backup and store it off the hub somewhere just in case (phone or computer). Then power the hub down using the shutdown option from that admin menu, take the power out for a minute or two, then start it back up again and restore from your backup. Then give it some time to settle.

Try to never cycle power on the hub without shutting it down first. Also, make sure it is cool and has plenty of air. If it seems to be running hot then turn it over so that the air holes are at the top. Also put it on a UPS to keep it powered and ensure it doesn't suffer power spikes. Finally make sure it had a good power supply of at least 1 amp.

Good luck. Hope you can get it resolved and back to good health again. I had many issues and the above ideas helped me, along with cleaning up apps and devices based on reviewing logs.

1 Like

Interestingly the hub is running pretty warm right now. It's been unusually hot outside the last couple of days and our house has got quite warm inside! This may be part of the reason... I've managed to download a few backups from the main UI then it stopped responding again!
Have shut it down from the admin menu and unplug, will then leave it to cool down for a while before powering up.
Do you think just letting it cool may help rather than the full soft reset? I will move it to a cooler part of the house too while in the process!

1 Like

The hub will start shutting down cores when overheating causing slowdowns. So letting it cool could definately help. You'll just want to make sure to keep the temp down when active.

1 Like

are you able to pinpoint a temperature? 90- 110 F shouldn't be a problem

It shouldn't have got as high as 110, we are only in the UK! More likely 90-100 tops. it is stored in a cupboard under the stairs it did get quite warm in there with some other electrical kit...

Try moving it to a cooler spot. Others have found this helps (check the forum). At least turn it upside down. But I would try it elsewhere for a while and see if that helps (appreciate you may need a long LAN cable and it's likely unsightly, but it's worth it for a test period I'd say).


Definitely worth trying a cooler spot before the soft reset, in my opinion. But if you are seeing a lot of red/errors in the logs including the text "sql" then your database may be squiffy due to your hard power cycles and then it's worth doing the soft reset. Remember that a soft reset won't lose any rules or devices from your radios, so you shouldn't have to redo or reset anything afterwards. But it will clean up the database if needed.

Definitely move it to a cooler place. Remember 110 Ambient is likely a heck of a lot hotter under the hood. I had regular lockups on my C4 when it was in a closet with other equipment. Ambient in that closet was typically <90f but....lockups.

Moved it more lockups.



I also have a C4! Having checked the logs I am getting errors from Alexa App and warnings for Harmony...
Have managed to resolve those (I think) but it still seems a little slow after a soft reset and restore.

For example, my Zigbee motion sensors are picking up motion and running the rule but the lights dont turn on, this is using Hue B Smart but has been fine up until now. Will leave things to settle overnight and see how things are looking in the morning

I have some further updates on this...

Since getting things looking more stable i then noticed that my event queue was full and getting lots of errors, never seen this before! Looking on here I found other users with the same issues relating to a driver for Xiaomi devices, I have now changed these to one that doesn't have the recovery feature enabled.
Will see how this goes now...

Had a feeling for a while the Xiaomi devices may be the cause of a number of issues we get!

1 Like

I agree, just pulled all of mine last week except 2 mains powered relays. The mesh seems somewhat more stable, less devices dropping but hub still gets slow, and this correlates with other user reported slowdowns, who don't have xiaomi devices or tons of rules. I'm sure the he team will figure this out, as soon as they're done ripping out their hair with the c7 issues :smile:

1 Like

So I have actually fixed the problem!
I think it is definitely down to something in the 2.2.3 firmware that is causing the xiaomi devices to spam the hub.
I have rolled back to 2.2.2 and the hub and automations are lightning fast again!
I am in the process of replacing my Xiaomi stuff and this has given me a kick to do so... Just need to find some UK sensors that are reliable and reasonably priced!

Try the new Sonoff zigbee v3 ones ( They seem excellent and are good value like the Xiaomis. Various posts about them on the forum.

1 Like

Just beware they ship without batteries.
Boo :face_with_raised_eyebrow:

Have just pre-ordered some from banggood. What batteries do they take?

I've got some of these Sonoff devices now, they have batteries in but can't seem to pair them.
Any ideas?

Use your Xiaomi/Aqara devices. :wink:
Seriously though, markus identified the issue and disabled that feature.
What Sonoff devices are you using now. I always like to try new devices.