Hub’s Web UI not responding

I bought a Hubitat C5 a couple years ago with the goal of replacing my Wink. I never got around to doing it, but with Wink down now for almost a week, I figured it’s time.

I updated my firmware to the latest, but the web UI does not respond, despite my hub having a green light. I can load the diagnostic tool just fine. If I revert back to the previous installed firmware version, I can access the UI without issue. However the previous version I had installed is very outdated (2.0.8) and I would like to start fresh on the latest version before trying to add all my devices. I’ve tried soft reset. I’ve tried hard reset. I’ve tried safe mode. Nothing is working.

Any help is appreciated. I sent an email to Hubitat support, but I haven’t gotten a response.

None of those have anything to do with the platform firmware. The hub is layered... Linux, then the Platform, which is Java mostly. Then comes your layer.. register, create a name, location, Rules and automations and the devices attached. Around here we lump all of that, your layer into "The DB".

Soft Reset simply blows away almost all of The DB, without losing your registration and so on. Rules and Automations are removed. Hard Reset goes a head and blow it all away.. pretty much how you'd want it to be if you were selling it. No trace of 'you' left. Therefore, stay as far away from a Hard Reset as you can, without some highly trusted advice to use it.

The Diagnostic Menu for Download Latest and Restore Previous are the way you affect the Platform... v2.0.8 to 2.2.5

If it were me, I'd try and follow the upgrade steps found in most of the 2.2.5 topics:


I downgraded back down to 2.0, and installed the latest again. There was a newer version in the last couple of days. When I update it, the light stays solid blue. When I revert back to version 2.0, the light comes on as green. For some reason, it seems that it’s not recognizing the newer platform version.

EDIT: It actually did turn green, but I’m sitting at the latest platform version and nothing loads when I navigate to the UI in the browser. Again, the diagnostic tool loads fine.

The app says “No response from hub”.

Overall, I’m incredibly frustrated with the fact that I am not allowed to choose which version I want to install. Based on the number of threads about issues with this release, it seems isolated to this newest version. If I had the option to download 2.2.4, I could at least install that and start setting up my device. Since the only option provided is to install the latest version, which clearly has issues, my Hubitat is an expensive paperweight until the issue is solved.

With Wink being down, I’ll give it a couple more days to get solved. It seems so difficult to find a reliable smart hub. I’d prefer not to ditch Hubitat for SmartThings before I can even give it a chance, but so much of this seems half-baked.

The latest version doesn't have the issues, its the upgrade that is the issue.
The latest release has a fix to stop this from happening but you need to load it for it to work. Chicken and egg situation.
I would follow the advice given and get your hub up to the latest. If you don't you could still have the issue in 6 months time.
Good luck. :crossed_fingers:

1 Like

If you have 2.2.5 up and running (even if it is flaky), you can point to one of these URLs: http://your.hubs.ip.address/hub/advanced/download222, http://your.hubs.ip.address/hub/advanced/download223 or http://your.hubs.ip.address/hub/advanced/download224, to get the last versions of 2.2.2, 2.2.3 and 2.2.4, respectively.

1 Like

If you have 2.2.5 up and running (even if it is flaky), you can point to one of these URLs:

Unfortunately, the UI is not responding at all, so those links don’t load.

Please try reverting to 2.0 and updating to (out just this morning).
That version should deal with the "stuck update" problem.

I have followed the advice given every which way, and it’s not working. I’m not sure how you can rule out the release, because there are a lot of threads about people having the same exact issue updating and having to restore a previous version. There is advice floating around to install latest, then restore previous version, then “restore” to the latest again. That didn’t work for me, and it also didn’t work for other people in threads I was reading.

I’ve restored back to 2.0, installed the latest, restored back, restored back to latest, shutdown at various points, rebooted, soft reset again. I’ve done this process with slightly different variants 8 or so times with no luck.

Every single time, if I revert back to 2.0, it works again. If it was a problem with the “upgrade” and not the release, then I would not expect 2.0 to work 100% of the time, and 2.2.5 to work 0%.

I understand the frustration and apologize. It took several versions with enhanced logging and some time for me to figure where things were getting stuck.

That’s what I’m afraid of. I think I’m in a potentially unique situation, because I have such an out of date hub. Maybe a dependency from a previous version was overlooked, and I’ll never actually be able to upgrade from 2.0 to 2.2.5 directly. Since the platform never actually loads, unless there’s a way to view the Linux logs, there’s nothing I can do to help my situation, and there seems to be little anyone else can do either, since none of the advice is producing any different results.

Just to be clear, did you follow @gopher.ny recommendation to try the upgrade again with the new build released this morning? I know you’ve said you tried it multiple times, but it’s unclear to me if you tried with the latest build from today that has specific fixes for this issue.

from the Diagnostics Menu (port 8081)

Ahh gopher suggested I try 126 the same time I sent my follow up message, so I missed that one.

Just tried .126 and that solved all of my issues. Though I'm not sure if there was something else as well. This time, when I reverted back to 2.0.8, it had a notification that my hub was not registered, so I registered it again. When I rebooted after registering, it said there was an update. I updated to 126 and it booted up with no issues.

I'm so appreciative of gopher and csteele for helping solve this issue.