Hub registration gone from account(s)


recently bought and installed two c-7 hubs for two residences I own. Originally, I registered both under the same hubitat account. Later, I decided that I'd rather have each hub registered to a separate account. I created a new hubitat account and de-registered one of the hubs from the original account. It all seemed to work as I verified that each account had the correct hub associated to it. That was one or two days ago. Since, I upgraded both hubs to the latest software version. Then today, while troubleshooting an issue with the hubitat alexa app, I noticed that each hubitat account no longer had a hub registered/associated with it. But when I look at each hub info, it still shows the email of the hubitat account it was registered with... Any help unraveling this would be much appreciated.

Edit: Additional info: cloud connection is off for both hubs. I would assume that this is due to the fact that the hubs are not associated to an account? Network connection seems ok as the ping host and traceroute in network test complete successfully...

Did you, by any chance, recently change the hubs from using DHCP to a static IP address directly on the Hubitat hub? If so, you may need to simply add a dns server setting of to the hub. Or, just revert back to using DHCP on the hubs, and reserve and address for each of them in your router’s DHCP server settings.

1 Like

Thanks for the reply. One of the hubs is on dhcp but has an address reservation. For the other one, since the router (xfinity) does not allow dhcp reservations I have set up a static address and is one of the dns listed (the other being and Again, both hubs, even though they are in different physical locations, and even though one is on static ip and the other on dhcp reservation, are both unlinked from my hubitat user ids. Both of them in their info page have the email account still listed. Wondering if anyone in support can take a look from the backend after I provide mac address and wan ip address and whatever else they may need to investigate this. I am new here and not sure how to get support to assist other than post on this forum. Do they have a support email? Thanks again for any assistance

Little curious, but why are you using non private IPv4 addresses?
The adresses you are using are owned by Google..

@fanmanrules thanks for the reply. If you are referring to the etc., those are the google dns entries for the static ip address. my internal network in on 192.168.x.x Sorry for the confusion.
Btw, when I set up static ip on my hub, the dns is automatically configured as in below picture:

For any and all warranty claims, please visit

The reason this might happen, is because the admin account on the cloud side now reflects the new account, but locally (on the hub side) with hub(s) not being able connected to the cloud, the change was not applied. The registration is solely a function of cloud service and not required when hub is used in offline. Connecting the hubs to the cloud will resolve the account issue.

Yea, that’s actually a common issue. Those DNS settings in the image may not really be there. Type in the DNS entry box, save it, and reboot the hub. It may then connect to the Hubitat cloud server correctly.

@ogiewon I followed your advice and it fixed it! I set both hubs to regular dhcp and after the required reboot they were both connected back to the cloud. Now both hubs are back on static ip and working fine. Still a mystery why this occurred in the first place given that the dns entry was always there (it is put in automatically when you configured static ip). I will keep to myself any speculation on the root cause :slight_smile: and I thank you for your help

Luigi T


Over the years my experiance as an Infrastructure tech, is that external (read Google) DNS servers do not always play nice.
Local DNS is always prefered.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.