Hub process slowdown after several days

I don’t see a need for echo speaks anymore. Since you can create virtual contact sensors and expose that to Alexa. Then within Alexa create a routine to say whatever you want.

I’ve also got rid of MyQ and rely on HomeKit which I use all the time to trigger a vs on or off. That’s how I get two way communication not needing another app.

The only apps that remain is a virtual precense switch done by cobra (which I could remove too and make some rule machine rules to do the same thing) and watchdog.

That’s it. I haven’t had any slow downs in almost a week so far....

Don't want to thread-jack here, but I want to be sure that those who need to use Alexa devices for TTS are aware there's an alternative to Echo Speaks, namely @ogiewon's Amazon Alexa Text To Speech (TTS). I have used it pretty much continuously since switching to Hubitat (~6 months ago), and have never experienced any hub slowdowns that I can ascribe to it.

This has been mentioned before. I should point out that while it is clearly an option to consider (any may be sufficient for most needs), it lacks the flexibility offered by apps such as @ogiewon's Amazon Alexa TTS, including the capacity to use variables, repeat a certain number of times or indefinitely.

2 Likes

The variables are the reason I use it. Much simpler to set up, and can then hear the data points such as temperature, etc. I did it this way because I didn’t want to install another app on the HE (already using HubConnect for Homebridge), and I had a SmartThings hub laying around collecting dust when not updating zigbee devices.

1 Like

For me it's the repeats.

Being told once that the dryer is done and clothes need to be folded merely elicits a sigh from me. Repeating that message five times at 2 minute intervals is sufficient to rouse my lazy arse into action ..... :joy:

8 Likes

I am an amateur enthusiast who migrated to Hubitat from Wink around 6 months ago. I have really enjoyed puttering around with my Hubitat and I have amazed myself with how I have developed such an affinity for implementing various smart home devices.

Alas, as a 70 year old retired guy with too much time on his hands, I enjoy the darn Hubitat so much that I have developed this nasty habit of fixing things that are not broken. For instance, I too have noticed a response time slow down on many of my devices and have followed this thread with interest. I was especially interested in the comment about using a soft reset and immediate data base restore to perhaps speed up all processes. As I always do, I researched how to accomplish this and did so. Well, all hell broke loose - my Echos no longer responded to voice commands and when I finally got it to work, my TV came on instead of a lamp with an Echo voice command, lol. Being persistent, I rebooted , unplugged my Hubitat and I almost gave it mouth to mouth, for crying out loud. You know what? The system is working better than ever!

My two cents - keep going with the same business model and product development. It is nirvana for old guys like me and the sense of accomplishment when something works is wonderful and I don't have to think about my aging prostate at last!

8 Likes

You can do repeats. Just do it in rule machine to open the contact sensor over and over again.

1 Like

I discovered that a reboot is necessary after doing a soft reset and restore from a backup. The first time I did a soft reset and restore, I almost had a heart attack when I saw that all of my information was missing. Luckily I realized that the restore info hadn’t been loaded since the hub didn’t reboot afterwards.

This is a bug that we are aware of, and will get resolved.

3 Likes

Is the virtual contact working for you? I see the sensor change in the Alexa app, but it never says the message.

You setup a routine to say something on the state change

1 Like

I did that and the echo says nothing, I do get it when I run the routine from the echo app.

I’m going to get to the bottom of this but I might need some other devs to help.
I’m just not seeing any flaws and some fresh eyes on the code since I don’t see the issue on my hub. It’s much more complex to debug.
If anyone is willing just reach out to me on here and we can chat on the Echo Speaks slack.

3 Likes

Now are people referring to the old ES or the V3 echo speaks ?

2 Likes

For me, performance hit when on ES, removed and performance went back to normal. I installed V3 and all is well... as it relates to performance

Rick

2 Likes

Ok.. Well that is definitely useful info. So V3 is not exhibiting the same performance issues as v2.

I just had some ideas to make things better for v3.1. It's annoying when it takes stuff like this to rethink an idea :wink:

I will push off some of the new zones app to v3.2 and release v3.1 this week.

1 Like

see i've had V3 installed since the 10/9/19 and have not noticed my automations / system slowing down. I have had no experience with V2 as it looked too big to tackle for me.
I get the usual/random motion lighting issues - but 99% of the time the fire rates have been acceptable for the last 2 weeks (I can only really measure slowness by the automations/browser response times).

My hub is starting to slow and taking 2-3 seconds from button press to action for lighting. I have everything disabled except HE apps and HubConnect. The logs are not showing a lot of traffic for HubConnect, in fact, with logs turned on for most things, it is just a ping here and there from my other hubs. I am seeing some strange messages for the Lutron Telnet - the getRetry up to the heartbeat...Happening fairly frequently. I have all kinds of debugging turned on to try and find the source of this slowdown.

Have you tried a Soft Reset to rebuild the DB on that hub. The getretry is every min, can't imagine that's causing it.

Also see if the hub is overheating too, I've seen a few posts about overheating that they flipped their hub upside-down to help vent the hub more.

What kind of button and what kind of light? is the web UI also feeling slow to load?

The button was just WNBA example. All automations, whether a button activated lamp, or motion controlled, are slowing down and are currently about 2-3 seconds slower than 2 days ago, when I did the soft reset, per directions from support. I don’t believe the hub is overheating, it is mounted in the wall of the laundry room, vents out. The case doesn’t feel hot. I would think if it was heat related, it slow down faster. The logs don’t have a ton of traffic. I have since turned on debug logging for about everything, and the only things coming through are normal Zigbee and http status updates.