Hub not running on port 80, but on 8080

I just got a new hub and it gave me a lot of problems to get the light green. Now that's solved, but the hub is not running on port 80. It took me 3 different routers - I went to friends' houses as well - and several port scans to be sure it's not an internal network problem. I'm pretty sure it's only running on port 8080 for the control panel.
I could live with that, but it breaks other things, such as speech to text.
Also I tried opening a ticket, but they said "It's your network" and closed the ticket. It was a bit frustrating, seemed to me like a lack of interest. So they pointed me to the community and here I am asking for help

Thanks in advance


The only other idea I have sounds like something you would have effectively tried anyway, but if you haven't 100% ruled out network oddities at both your and your friend's house (I know, unlikely) by plugging both your computer and hub directly into the same "dumb"/un-managed switch or router-type device, it can't hurt. The C-5 and later hubs also have the ability to use Wi-Fi instead of wired and to manually configure some network settings instead of relying on DHCP, but I'm not sure that either would really address this odd problem.

I'm not sure that I have any more ideas, but maybe someone else will chime in.

1 Like

Were you using the same computer and O/S/browser to access the hub in all cases? Looks like something is blocking port 80 rather than the hub isn't listening on this port.


Hi there, thank you for reaching out for help. The ticket is not closed, but we ran out of ideas and escalated it to our engineers to see if they have any suggestions.

1 Like

Mine happened after I updated to the latest firmware. Before updating I didn't see it happening.

Would it be possible to flash the firmware image with a TFTP ou maybe with a serial interface?

1 Like

I'm my case I tried with 2 different PCs, a tablet and 2 cellphones, I connected directly with cable PC-HUB, and I brought it with me in my home where I have also a HUB that is working just fine.
The feeling I have is that the Http server on the hub got corrupted.

1 Like