Hub Mesh Follow Mode Broken in 2.2.5.120?

My hubs are no longer syncing mode changes since updating them to 2.2.5.120. They might have stoped syncing in the prior update, but only noticed the issue today after applying the hotfix. The hubs see each other and appears to be sending device updates, but not modes.. All my hubs only show "Use local modes only" in the dropdown, you can't select any of the other hubs in the drop down.. Prior to the update this worked just fine...

I have one hub which acts as "primary" in which my two other hubs are "secondary" and would use the mode from the "primary" hub. This worked great, until this release.. I have tried rebooting all the hubs more than once. Ideas?

Noted, will check it out.

1 Like

Hmmm ... works for me. Updated to 2.2.5.120 yesterday and my "slave" hub's mode followed the "master" hub's mode this morning (Night to Day) .... and just followed another change from Day to Night approximately an hour ago.

Mine are syncing, but I see this on the slave hub:

i just confirmed my C7 is following my C5 as expected.
But I have the same screen as above ... so something is not right.

Ah, I see what you're saying ... yeah, same display on mine, but it does sync :thinking:

It appears that if you already have it set up it works. I realized that after I noticed that one of my hubs was still updating, But if you make changes it gets set to local and there’s no ability to re-enable as the UI doesn’t show the remote hubs in the drop down, as depicted in your screen shot.

If you change your hub mesh settings that’s when it breaks, at least that’s what appears to have happened in my case. I had added a new device on the hub that’s no longer syncing.

I have temporarily started using virtual switches to change modes on the remote hub until there’s a fix.

Word of warning, if it’s working for you right now don’t mess with it or you may be stuck like me. :frowning:

3 Likes

I will not be messing with it. Thanks for the heads up.

2 Likes

I have a rule which tells me when certain devices go OFFLINE.
3 devices where reporting this every hour after the .120 upgrade.
When I checked the slave device it showed up as "hubmeshdisabled=true".
Checking the device it was synced ok and working as it should.
By disabling and renabling hub mesh for the device it then changed to false.
All ok now but thought I would mention it in this thread.

I'm seeing the same UI problem: even though my other three hubs are shown correctly in the "Active local hubs" section just above, there's nothing under " Follow another hub's mode changes" other than "Use local modes only", and the "Search" in that drop-down can't find anything.

Despite this, Mode updates across hubs are still working.

I also am seeing this in the current states for some mesh devices:

image

Not sure how/when that happened.

Do devices get their updates?

trying to figure that out right now.... Would the event log be an indicator or would that sync?

EDIT: Yep, on a simple virtual switch turning it off/on on the source hub it does show the event on the meshed remote hub. So it appears to be syncing even though that shows false. @gopher.ny

@jrfarrar @gopher.ny
I posted about this issue in post #9.
Disabling and reenabling the mesh function on the physical (not mesh) device gets it back to normal.
Don't know what caused it though.

For information, I have 3 hubs and I update them all at the same time.

Ditto the above. Enabling/Disabling on the source refreshes the state. I did confirm that they seem to be working even without doing that. I ALSO have 3 hubs and update at the same time. (just adding for info)

1 Like

@gopher.ny
Just for information.
Updated all 3 of my hubs to .122 and the situation I had of incorrect hub mesh state being displayed doesn't look to have happened again.
:man_shrugging:

1 Like

Mode dropdown should be populated properly in 2.2.5.122.

3 Likes

...you guys are killing me with the speed of fixes :rofl:

3 Likes

I have a different problem. After updating two hubs to 2.2.5.120, the hubs periodically lose contact with each other. If I look at the mesh setup page there are no active local hubs. The hubs are on the same subnet, I have tried both UDP and TCP. They are, however, hanging off two different nodes on a meshed wifi network. I had this same situation yesterday and it somehow resolved itself but now it's back again, only to resolve itself again in a few min. This was definitely not an issue on 2.2.4.158. Is this also fixed in 2.2.5.122?

Haven't heard of this issue before, and no, updating to 122 will not make a difference.
Please use TCP over UDP if connections drop. Rebooting the routers once in a while might help, too.
I'll look into this, but it might be hard to reproduce.

Download the Hubitat app