Hub Mesh between 3 hubs (SOLVED)

I have 3 hubs one is not finding the other two on Hub Mesh (There are no other active hubs on the local network.)

The other 2 are working fine together all 3 are running 2.2.8.136, I'm not sure if this happened after the 2.2.8.136 updates

Is the 3rd connected to a different access point? Have you tried the TCP protocol? Or if the two hubs that can communicate are using TCP, is the third using UDP, by any chance?

2 Likes

That's it' the one not working was on UDP the others on TCP, all 3 on TCP now and everything is working fine,

Thanks very much :+1:

4 Likes

Partially off topic but close enough I think... I too am running three hubs (one in each building) in a home environment. My setup has them all running on separate IP's with one being a "master" has all the dashboards, apps and automations. The other two are in essence slaves where all their devices are shared with mesh to the master.

everything seems to be working as I expect, so my questions are:

A) Is there any advantage to running them all in the same IP?

B) How are they running on the same IP without the router bitching about dup's??

If they’re all in a common subnet, they cannot share a single IP address.

Awesome. May I suggest editing title to solved, maybe making it something like "3 hubs-inter hub comm issue-SOLVED" this way later solution seekers will be able to locate :grinning:

4 Likes

@zapbust - I liked @Rxich suggestion very much, so i changed the title. Apologize for jumping in there before you got a chance to. You can change it again to whatever you like ….

2 Likes

Have you tried UDP on all three? It is the recommended protocol as it is slightly faster and less overhead. If your hubs are on different subnets, it probably won't work.

1 Like

Just moved them all to UDP and everything is fine :+1:

2 Likes

Download the Hubitat app