Hub Link Issue


yep, I do:

Here's their properties:

(Status table is empty on both except for Create Time)

OK, thanks. Somewhat of a mystery at the moment. The logs on the ST side show that ST is sending the setup information to HubLink, while the absence of a log entry on the Hubitat side suggests it is not receiving it.

We will delve further into it...

1 Like

Any update regarding the new firmware release? Bobby mentioned you identified the issue and will deliver a fix soon.

We are not able to reproduce the problem you reported. As far as I can guess, perhaps you have some LAN issues. No clue what those might be.

There are definitely no network issues whatsoever on my side. Hue bridge integration is working fine and so is every other network application. I was really hoping there would be a resolution coming with a firmware update because Bobby said so in my support ticket (#10607).

I just updated to firmware version, but nothing changed regarding the hub link issue. ST Live Log says it's sending information to Hubitat's IP address, but apparently nothing is registered there. I have no clue what might or might not be going on with Hubitat because log output is not exactly verbose.

You're welcome to take a look yourself using some sort of remote control software, because I have no clue what else I should try.

He was mistaken. As I said, we don't know what the problem is. I will check to see if there is anything we can do remotely...

Problem solved. Thanks Bruce and Bobby!

1 Like

What was the solution?

There had been a text url entered instead of an IP address, and that was causing the hub to barf on it. He was able to clear that out with our help.

Next release will enforce proper IP addresses only, and also clear out any bad ones found. The app needed some hygiene improvements.


barf being a technical term?

yes, it's a very well known technical term., along with puke :smiley:


I have the same problem, can anyone let me know how to clear the text url? thanks.

I have follow all the directions and pretty sure I have it all set up correctly including the correct ip address. My problem is that the door locks I have on the ST system show up as virtual locks on hubitat but do not work when I push to lock or unlock on the HE. Are locks just not compatible in this way?

I suggest using this app for ST compatibility

1 Like

@bravenel I'm seeing log entries every 5 minutes for most linked switches on the master hub. They don't show as events on those linked devices and also there are no events happening on the linked hub actual device. Is this something new or I've just never noticed these entries?

Would you turn on debug logging on the real Tiny Kitchen Sengled and see if it is sending out off events or not?

Also what driver are you using?

I think you solved it with your question @mike.maxwell.

I'd forgotten how I'd done the trick using a STs driver to deal with those bulbs not showing accurate state when power was cut to them. I'd loaded that driver, clicked configure, then reloaded the stock HE generic zigbee drive without clicking configure.

When I just tested with two of these bulbs that were sending off on signals every 5 minutes and click the configure button, that stopped them from sending redundant off ons every 5 minutes.

Are you going to be able to do something with that generic driver for Sengled bulbs to help them report accurate state when the power is turned off to them?

At some point yes, bulbs are on the short list for an overhaul.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.