Hub is randomly rebooting

My hub (the older version with usb Zigbee/Zwave Stick) started rebooting randomly. 3 or 4 times a day. Coincidentally. yesterday I discovered 2 of my Smart Things Water Sensors had not checked-in recently. Rebootings by battery removal didn't bring them back, so I reset them and ran discovery one at a time. A previously paired device was found and when I clicked on that discovered device, my hub rebooted. This happened both times. Maybe Database Corruption Issues?? I do have some manual backups. I could restore from one of them but that is last resort since I did a poor job of documenting why backups were made and have no timeline of changes after each to know what I am restoring to. Sure wish hubs were in stock.

The hub backs up daily as well and keeps 5 backups.

yes but they are too recent. My reboots go back about 2 weeks i think.

@csteele has explained things better then I can.

Soft Reset Instructions

1 Like

Well after reading the info about a soft reset I decided to go ahead with that. I restored to the 2 day old backup. Fingers Crossed

1 Like

Is there a way to monitor or see the Hub uptime?

Click the Hamburger in the upper left, then System Events, Hub Events and search for systemStart. This will show the last time your hub booted.

1 Like

You can also use systemStart in RM to send you a notification on hub reboot. Very handy.


No systemStart is found. My logs are truncated to about 45 minutes. I spent the evening going over RM and was not able to figure out how to use a rule to monitor for an event. If the hub is crashing rather than rebooting would there be enough time to send a notification?

I have turned all debugging off and have gone over all my rules to see if something is weird. They are mostly simple. Nothing so far and I am still rebooting

In reply to a post above about getting notifications on a hub reboot, this is what I have set up. I do a reboot once a week at 01:30, hence the rule structure.

Location Event


Awesome. I bow before your greatness. I had looked all over the Rule Manager looking for that SystemStart but I never had looked in that "Location" under triggers. Somehow long ago in a land far away, I had decided that it had something to do with physical locations and never made the logic leap to "Hey dummy!! maybe local events are in that LOCATION field. again thank you.

:::: and while I was typing my hub rebooted::::

I had to ask to find this initially as well.
I agree, it's the last place I would look.

Check the logs for any errors, post here if you have any.

  1. Is the hub in a well ventilated conditioned space?
  2. Try another USB Power Supply (At least 1AMP).
1 Like

I did the power supply swap early on. I assumed the hub was rebooting because sometimes a response to a command using the web page would cause the page to time out. But here is the interesting thing. I set a notification upon restart (thanks @bobbles) and didn't get any notifications and my router says the hub has been up over 23 hours. Turns out the hub is not rebooting. Something is happening to totally slow the hub down. The only thing I see in the log is a repeated [error] connection to BOND hub appears to be down. Check if the IP is correct.

I have assigned IP Addresses and is the correct Bond Hub address.

Duh, sometimes I am a freakin idiot. is MY HUBITAT ip address....
it must be the source address.

I do not have a bond hub, try posting the error to the App Release thread. Someone who uses the app may be more familiar.

Also you may want to check settings within the app, make sure it is updated.

If you cannot clear the error try disabling the app and see if your slow downs go away.

I am really starting to suspect this hub. It will barely stay up. cannot ping it, cannot get into :8080 or :8081. If I can get into diagnostics I'll try safe mode.

Tagging @bobbyD
If you can get back in I would recommend you disable the Bond app any anything else that is giving errors in the logs and see if you can get things stable.

1 Like

Sorry for the troubles. If you cannot access the Diagnostic Tool, I would try replacing the Ethernet cable. Also, worth checking your network to make sure you didn't accidentally assign same IP for two different devices.

Well I have tried to reset, revert to previous firmware. I even tried a full reset. the commands all fail. I occasional can get the web Gui but it times out when I select another page. Anyone know how to contact support