Hub is not connecting to the cloud

So it appears my C7 hub died while I'm out of the country for the foreseeable future. It became unresponsive yesterday and I can't reach it via Remote Connect. I was able to remotely kill the power and then restore the power 20 minutes later but it still remains unreachable. There is no one with any degree of technical prowess who can go to my house and troubleshoot. Why do you guys recommend? I suspect I'm SOL. I do have Hub Protect but I don't think that's going to be of an help in this situation.

And apologies for the Facebook cross-post. Desperate times, desperate measures and all that.

Hard to diagnose. Could simply be a corrupt database, could be the port it's plugged in to. Could be another dozen issues even it could have changed ip. (Can you go to and see if the hub is online?)

Can you VPN to the local LAN (or remote connect to a server/PC on the LAN)? Then you could try to reach the diagnostic port of the hub. With only remote admin if the main platform does not boot then you have no way to get in.

I checked your hub again after you've power cycled and it is still not connected to the cloud. It is very hard to troubleshoot without someone on site. Sending a replacement using the Hub Protect service wouldn't benefit you, as you'd also need someone there with minimal technical abilities. Can you power cycle your router remotely, too? That may help.

Problem solved. I had a friend go over and take a look and all is well again. The hub is connected to a Kasa smart plug so I can shutdown the hub and remotely power it off and on again when necessary. The smart plug had failed. Removing the smart plug and plugging the hub directly into the outlet solved the problem. I bought 4 Kasa smart plugs and the mortality rate is now 4 for 4. No more Kasa for me.

That's very unusual, those devices have been very solid for everyone else (including myself) AFAIK. I wonder if it is something with your power source causing an issue? Did they get fried from a surge maybe? I have had one plug in service on a lamp for years now and working fine, I have a switch with a bath fan connected to it (probably out of its specs) and never had an issue. I also have multiple seasonal plugs I use for holiday lights. They are probably the least problematic and most reliable devices I have, if they did not need to be polled for updates I would probably have gotten more (I think some of the newer stuff can work without polling now).