Hub IP did not update after LAN Subnet Update

I need some help. I recently migrated to a C-8 Pro from a C-8. Everything went well.

I needed some help from Peplink (B20X) with a WAN issue and they said it was a conflict with my LAN subnet and Starlink WAN. Suggested we change the LAN from 192.168.x.x to 192.168.x.x That worked well and solved the WAN problem but when DHCP devices updated my C-8 Pro would not update and kept it's old IP and was not accessible and was not on the Client List.

After 2 days of no Hubitat I deregistered the C-8 Pro and registered the old C8. That is where things are today. My issue is the local backup did not have any of my Apps and it looks like the cloud backups are gone.

I need help to change/access the IP of the C-8 Pro so it can be registered, hopefully with the Apps intact. - Thanks.

Deregistering it was slightly drastic.

Make sure if you have a reserved IP on the router it is set correctly to the new subnet range.

Do a network reset to clear any static IP settings and reset it back to DHCP: Network Setup | Hubitat Documentation

If you have a functional DHCP server on your network, there is no reason why the hub would not just pick up a new IP when you power it up. There is no way it would hold on to an old IP unless you have it set static on the hub.


It was drastic. I deleted all reserved IP's yesterday and did a LAN reset. It still does not show up. If I look for it with Find Hubs MAC it still shows the old IP address. I decided to see how the Old C8 would behave and it found it right away. I've been at this for a couple of days now and really stumped.

Did you try the network reset on the hub, suggested above?

1 Like

If you used the advanced find and searched by MAC, and it shows the old IP I think that actually scans the LAN. In that case it probably means that you have the IP set statically on the hub. The network reset will clear that, click the link above for the directions.

I did try the network reset earlier today. Just tried it again for a minute but when released it went to blue quickly and back to green. That did the trick. I now have access. Appreciate the help now to get it registered and see if I can locate a backup.

If you had done a free cloud migration backup recently, it should still be there. You possibly could not see it on the old hub because they are restricted for upgrades only so people do not abuse it as free hub protect. The free backups only work if you are upgrading to a newer model hub.

Also, unless you factory reset the hub, just deregistering it possibly did not wipe it out, you might be lucky. Still not sure why you de-registered it.


I got lucky. Cloud & Migration were not there because I had Xfered my Subscruptions back to C8. But, several local backup's were. I was able to get one to work and all Devices and App are back. Xfered Subscriptins back to C8P. Now just a matter of sorting out a few things but total disaster avoided. Somtimes you just need a little help from your friends. Thanks!


De-registering the hub doesn't do anything other than removing the admin account associated with the hub, which would disable some cloud functions, such as adding cloud connected integrations and saving cloud backups.

Resetting the network is the only action that could resolve a network issue on hub's side, which I see that it helped in your case.

Are you sure you ran the local backup after adding your apps? The cloud backup was gone because a. you transferred the subscription and b. you removed the registration. Once the hub is registered again, the cloud backups should become available again, assuming they were not removed due to the transfer of the service to another hub.

Was not "luck". It's how things suppose to work. One thing to keep in mind, is that when you transfer an active subscription between hubs, it deletes all cloud backups. There is a warning when attempting to transfer a subscription:

1 Like