Hub factory reset itself?

My hub has been working awesome up until yesterday. Noticed some of the basement lights didn't turn on. Then a sensor stopped working. I unplugged the hub and plugged it back in whcih at this point seems like a dumb move because logs may not be persistent?

After that, I logged into the local UI and it showed zero devices.

Any way to restore a previous configuration if this is common?

If the hub finds a corrupted database at startup, staff have mentioned it will resort to a previous backup. This normally happens every day around 2 AM hub time, any time you manually do an update or proper restart, and whenever you manually invoke one. You can download any recent backup or invoke one and download it at that time, which you can save elsewhere. If you haven't done that and don't see any backups in your hub itself (Settings > Backup and Restore), you might be out of luck. I'd definitely recommend manually downloading backups on occasion for this reason.

So, first I'd check to see what you find there. If nothing, hopefully Support will see this and may have other ideas (though you could always formally reach out). It's likely the forced reboot caused a problem, but if you had recent--even automatic--backups, I don't think it should have created this problem (unless you set up your entire hub all within the last day).

Good luck!

I just experienced this very unfortunately scenario.

I've spent the last two days setting up my new hub with dozens of devices, dashboards, Rule Machines, etc. and had not yet created a backup. The UI became non-responsive so I power cycled the hub and all my work is now lost.

Lesson learned I suppose but is there a way to automatically create a backup at X frequency and keep Y number of backups?

Also, if the consequence of a corrupted database without a backup is a reset to factory defaults, why isn't the UI alerting me that I need to create a backup?!?

As @bertabcd1234 mentioned last year, the hub creates backups automatically every day during its maintenance window ~2am-3am.

Have you tried the instructions here?

Found the automatic backups shortly after posting. Unfortunately, none of them worked.

I'm brand new to HE; have previous hw/sw versions been stable? I'm not terribly impressed with the resilience of the C-7 thus far.

The C7 hub is a pretty major hardware revision and has had some unique issues since it was released recently. They are hard at work trying to resolve them.

1 Like


I have not seen anything like this in the 18 months or so I have been on Hubitat. At worst, there is a bugfix a couple to a few days after the initial firmware release to "touch up' anything that surfaces.

I might be interpreting things incorrectly, but my impression is that part of this or some of this is due to flaws in the source Zwave firmware, not something Hubitat has messed up. In that case, I don't know what could have been done differently, especially if flaws didn't show up during testing.


That’s my understanding as well, from the info that’s been posted in various recent threads.

I do... They could have kept working with silicon labs to fix it prior to release and not released the product until it worked. :slight_smile:

That said, I'm just arguing for the sake of arguing. My hub is working great. LOL

1 Like